Skip to content

Commit

Permalink
dev-qt/qt-docs: version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
Pesa committed Dec 15, 2016
1 parent 9a8bf60 commit 1a8cdd9
Show file tree
Hide file tree
Showing 2 changed files with 35 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-qt/qt-docs/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST 5.6.1-1qt-everywhere-documentation-5.6.1.7z 125597447 SHA256 cf78e4f7dde039197c9962491fb13a99862fdc6eaf4c61b87388bf33e4071995 SHA512 65a7afada70489b382fcd5c7417f3ddb3c184eaa954042370bce26f96de98f9b068258239a0c5f14c73c802ce5428e214a6be4fb16010033f03a62f8f370f28d WHIRLPOOL 00ad1a4360f483dbdf8d6ce413c60fda0e4546c84fbdbb22de4d51a6ae9334e4c6de6bd402cb72cf088bb404d4836e87fa04147e784b373043fc6694c1162c07
DIST 5.6.2-0qt-everywhere-documentation-5.6.2.7z 125390155 SHA256 3421b5a2fba1f6e134137e4c9f747303bc2218c46b314dae858499aab850931c SHA512 40026c69e6b2de8f84fc974bc307519016982cafe4006ef3663839c9bcf74f7c28679cf8f4ca5a82bfafc3cb455433fe3360c11a60192d8c6b75a8b1b56e7141 WHIRLPOOL edd591be964208467700c91a02eb345f73f4104820b3f605b8e2d4c2704faccc681320bcfef5bfa70cc084b10cf2ada09d5771b0ac578193fd7eaafe0ee86477
DIST 5.7.1-0qt-everywhere-documentation-5.7.1.7z 173336041 SHA256 44eb231b5f961a9f11d05648431121bbdaa32ac65e6b563543d147c3b88eec41 SHA512 4fcbfcd29aa48937229d01d47569a5fcd81459b9444058c725bdbac14dd2b9c67c9e04944c74d351f4bca7d972e23c3832ba2dd8e979cc4e9fe677e2d51561e0 WHIRLPOOL 8a6e1857866e43f7f40ed4382e0d5b4f27520404a77f3a014834045117f207bb40a0a81aaa00afa39a4684584499f6957bf739a1f25d06c04019ef21dac1adfd
34 changes: 34 additions & 0 deletions dev-qt/qt-docs/qt-docs-5.7.1_p0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit versionator

MY_PV=$(get_version_component_range 1)$(get_version_component_range 2)
MY_P=${PV/_p/-}qt-everywhere-documentation-${PV%%_p*}

DESCRIPTION="Documentation for Qt5, for use with Qt Creator and other tools"
HOMEPAGE="https://www.qt.io/"
SRC_URI="https://download.qt.io/online/qtsdkrepository/linux_x64/desktop/qt5_${MY_PV}_src_doc_examples/qt.${MY_PV}.doc/${MY_P}.7z"

LICENSE="FDL-1.3"
SLOT="5"
KEYWORDS="~amd64 ~x86"

DEPEND="app-arch/p7zip"

S=${WORKDIR}/Docs/Qt-$(get_version_component_range 1-2)

src_install() {
# ${PV} instead of ${PF} is intentional
local dest=/usr/share/doc/qt-${PV%%_p*}
insinto "${dest}"
doins -r *
docompress -x "${dest}"

# these files are not shipped in any other version of qt-docs and collide with qtcore
# bug 597026
rm -rf "${ED}${dest}"/global || die
}

0 comments on commit 1a8cdd9

Please sign in to comment.