Skip to content

Commit

Permalink
app-admin/augeas: Revision bump to fix several ebuild issues
Browse files Browse the repository at this point in the history
* Move eautoreconf to src_prepare()
* Use addpredict instead of addwrite
* Do not run econf multiple times (USE flags were being ignored)
* static-libs USE flag should not disable shared libs
* Prune .la files

Signed-off-by: Sven Wegener <[email protected]>
Package-Manager: Portage-2.3.49, Repoman-2.3.10
  • Loading branch information
swegener committed Sep 24, 2018
1 parent 0f5de69 commit 1b02322
Showing 1 changed file with 49 additions and 0 deletions.
49 changes: 49 additions & 0 deletions app-admin/augeas/augeas-1.11.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools

DESCRIPTION="A library for changing configuration files"
HOMEPAGE="http://augeas.net/"
SRC_URI="http://download.augeas.net/${P}.tar.gz"

SLOT="0"
LICENSE="LGPL-2.1"
KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ~ppc64 sparc x86"
IUSE="static-libs test"

RDEPEND="
dev-libs/libxml2
sys-libs/readline:="
DEPEND="${RDEPEND}
virtual/pkgconfig
>=app-doc/NaturalDocs-1.40
test? ( dev-lang/ruby )"

PATCHES=(
)

src_prepare() {
default
eautoreconf
}

src_configure() {
# selinux needs to implemented
econf \
--without-selinux \
$(use_enable static-libs static)
}

src_compile() {
addpredict /usr/share/NaturalDocs/Config/Languages.txt
addpredict /usr/share/NaturalDocs/Config/Topics.txt
default
}

src_install() {
default
use static-libs || find "${D}" -name '*.la' -delete || die
}

0 comments on commit 1b02322

Please sign in to comment.