Skip to content

Commit

Permalink
dev-haskell/pandoc-citeproc: fix USE=-bibutils build, #516640
Browse files Browse the repository at this point in the history
Reported-by: Thomas Beutin
Bug: https://bugs.gentoo.org/516640

Package-Manager: portage-2.2.27
  • Loading branch information
Sergei Trofimovich committed Feb 24, 2016
1 parent de00f8e commit 1b0ef9a
Show file tree
Hide file tree
Showing 3 changed files with 34 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
Fails to build with -f-bibutils:
https://bugs.gentoo.org/516640
diff --git a/pandoc-citeproc.hs b/pandoc-citeproc.hs
index 7006e02..f72fa41 100644
--- a/pandoc-citeproc.hs
+++ b/pandoc-citeproc.hs
@@ -1 +1,2 @@
+{-# LANGUAGE CPP #-}
module Main where
@@ -75,2 +76,3 @@ readFormat = go . map toLower
go "bibtex" = Just Bibtex
+#ifdef USE_BIBUTILS
go "ris" = Just Ris
@@ -87,2 +89,3 @@ readFormat = go . map toLower
go "yaml" = Just Yaml
+#endif
go _ = Nothing
diff --git a/src/Text/CSL/Input/Bibutils.hs b/src/Text/CSL/Input/Bibutils.hs
index 081fa91..49ddbd0 100644
--- a/src/Text/CSL/Input/Bibutils.hs
+++ b/src/Text/CSL/Input/Bibutils.hs
@@ -64,3 +64,3 @@ readBiblioFile f
#else
- _ -> error $ "citeproc: Bibliography format not supported.\n" ++
+ _ -> error $ "citeproc: Bibliography format not supported.\n"
#endif
4 changes: 4 additions & 0 deletions dev-haskell/pandoc-citeproc/pandoc-citeproc-0.7.2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -49,6 +49,10 @@ DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.12
"

src_prepare() {
epatch "${FILESDIR}"/${PN}-0.9-no-binutils.patch
}

src_configure() {
haskell-cabal_src_configure \
$(cabal_flag bibutils bibutils) \
Expand Down
4 changes: 4 additions & 0 deletions dev-haskell/pandoc-citeproc/pandoc-citeproc-0.8.1.3.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -51,6 +51,10 @@ DEPEND="${RDEPEND}
embed_data_files? ( dev-haskell/hsb2hs )
"

src_prepare() {
epatch "${FILESDIR}"/${PN}-0.9-no-binutils.patch
}

src_configure() {
haskell-cabal_src_configure \
$(cabal_flag bibutils bibutils) \
Expand Down

0 comments on commit 1b0ef9a

Please sign in to comment.