Skip to content

Commit

Permalink
net-libs/zeromq: fix test_security_zap
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/673472
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Jan 15, 2019
1 parent b13b006 commit 1b14dc8
Show file tree
Hide file tree
Showing 2 changed files with 26 additions and 1 deletion.
25 changes: 25 additions & 0 deletions net-libs/zeromq/files/zeromq-4.3.1-fix-test_security_zap.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
From 4147957a5eec57ec7a2a416dca74c3c0299a3432 Mon Sep 17 00:00:00 2001
From: Luca Boccassi <[email protected]>
Date: Sun, 13 Jan 2019 13:08:10 +0000
Subject: [PATCH] Problem: test_security_zap fails on architectures that
disallow unaligned pointer access

Solution: use memcpy instead of doing pointer arithmetics with casting
and dereferencing to fix the error on sparc64
---
tests/testutil_security.hpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/tests/testutil_security.hpp b/tests/testutil_security.hpp
index 90999118c..437bfb298 100644
--- a/tests/testutil_security.hpp
+++ b/tests/testutil_security.hpp
@@ -345,7 +345,7 @@ static int get_monitor_event_internal (void *monitor_,
uint8_t *data = (uint8_t *) zmq_msg_data (&msg);
uint16_t event = *(uint16_t *) (data);
if (value_)
- *value_ = *(uint32_t *) (data + 2);
+ memcpy (value_, data + 2, sizeof (uint32_t));

// Second frame in message contains event address
zmq_msg_init (&msg);
2 changes: 1 addition & 1 deletion net-libs/zeromq/zeromq-4.3.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -26,7 +26,7 @@ DEPEND="${RDEPEND}
)
pgm? ( virtual/pkgconfig )"

PATCHES=()
PATCHES=( "${FILESDIR}"/${P}-fix-test_security_zap.patch )

src_prepare() {
sed \
Expand Down

0 comments on commit 1b14dc8

Please sign in to comment.