Skip to content

Commit

Permalink
dev-perl/IO-Socket-SSL: Bump to version 2.39.0
Browse files Browse the repository at this point in the history
- EAPI6
- Add USE="examples"
- Parallel Testing

Upstream:
- Fix memleak with SSL_crl_file
- Follow Mozilla cipher recommendations for defaults, disabling
  RC4 and adding CHACHA20 for clients.
- Add del_session method to session cache
- use SSL_session_key for the cache key instead of a derivative
- Don't re-add existing extensions
- Support creating ECC keys
- Direct Cache IO instead ov via session_cache sub
- Set session id ctx only server side.
- Support session ticket reuse
- Support OpenSSL >= 1.1.0c
- Global SSL arguments handled in context creation
- Disable OCSP w/ Net::SSLeay 1.7{5..7}
- Extend SSL fingerprint to pubkey digest
- Restrict session ticket callback to Net::SSLeay 1.79+

Package-Manager: portage-2.3.2
  • Loading branch information
kentfredric committed Nov 21, 2016
1 parent 3e6905b commit 1b4fab7
Show file tree
Hide file tree
Showing 3 changed files with 36 additions and 0 deletions.
30 changes: 30 additions & 0 deletions dev-perl/IO-Socket-SSL/IO-Socket-SSL-2.39.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

DIST_AUTHOR=SULLR
DIST_VERSION=2.039
DIST_EXAMPLES=("example/*")
inherit perl-module

DESCRIPTION="Nearly transparent SSL encapsulation for IO::Socket::INET"

SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="idn"

RDEPEND="
>=dev-perl/Net-SSLeay-1.460.0
virtual/perl-Scalar-List-Utils
idn? (
|| (
>=dev-perl/URI-1.50
dev-perl/Net-LibIDN
)
)"
DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
"
mydoc=("docs/debugging.txt")
1 change: 1 addition & 0 deletions dev-perl/IO-Socket-SSL/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST IO-Socket-SSL-2.024.tar.gz 209567 SHA256 dab3125b004b24ff8dfc003aa81c00c0f976a1bc34a75e1d8d9de9de837ce6c9 SHA512 b76c43efbffba031b72efebc9f5348eb24ea1d48704e61c2256c0a23a754fb786cad23d7a330884f526ed31fc2878e27f4114793afa8135cc0caf8f251c07c3c WHIRLPOOL 37ae14c700a21a89fad3ca653925e07272d51a2f4ecee2a5342909d49491f42b3d3ee6e318fbb5d6a02ead1479916a6775e48f61cb3722d9526795482ae5ee58
DIST IO-Socket-SSL-2.039.tar.gz 213906 SHA256 c6379a76860c724a22b79ebe9e91d26bd8a04e3ce035bacfd15de3d9beaf83ac SHA512 e107a5bdd1631d87e11fbb339e13b4c3272db3a7ca43488c221bbd17c7a93f2033e175c0ca8ee6e89f45550a68741c4762880845378dca7f0beaa45427399515 WHIRLPOOL e117469c5f0226d80ac3ac714cff72e0c3705a367c5008f57216c50af137928ff3ca99e0741a5e93f76236f60996af830bfbac269f1e045da53cfc685d7403b9
5 changes: 5 additions & 0 deletions dev-perl/IO-Socket-SSL/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -8,8 +8,13 @@
<upstream>
<remote-id type="cpan">IO-Socket-SSL</remote-id>
<remote-id type="cpan-module">IO::Socket::SSL</remote-id>
<remote-id type="cpan-module">IO::Socket::SSL::Intercept</remote-id>
<remote-id type="cpan-module">IO::Socket::SSL::OCSP_Cache</remote-id>
<remote-id type="cpan-module">IO::Socket::SSL::OCSP_Resolver</remote-id>
<remote-id type="cpan-module">IO::Socket::SSL::PublicSuffix</remote-id>
<remote-id type="cpan-module">IO::Socket::SSL::SSL_Context</remote-id>
<remote-id type="cpan-module">IO::Socket::SSL::SSL_HANDLE</remote-id>
<remote-id type="cpan-module">IO::Socket::SSL::Session_Cache</remote-id>
<remote-id type="cpan-module">IO::Socket::SSL::Utils</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit 1b4fab7

Please sign in to comment.