Skip to content

Commit

Permalink
kde-apps: Add {kde,kde4,kdepim,ktp}-l10n-15.12.1 from kde overlay
Browse files Browse the repository at this point in the history
  • Loading branch information
a17r authored and kensington committed Jan 31, 2016
1 parent 5c09898 commit 1b54bdf
Show file tree
Hide file tree
Showing 9 changed files with 818 additions and 0 deletions.
54 changes: 54 additions & 0 deletions kde-apps/kde-l10n/Manifest

Large diffs are not rendered by default.

119 changes: 119 additions & 0 deletions kde-apps/kde-l10n/kde-l10n-15.12.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,119 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

KDE_HANDBOOK="true"
inherit kde5

DESCRIPTION="KDE internationalization package"
HOMEPAGE="http://l10n.kde.org"

DEPEND="
$(add_frameworks_dep ki18n)
dev-qt/linguist-tools:5
sys-devel/gettext
"
RDEPEND="
!<kde-apps/kde4-l10n-${PV}
!kde-apps/kde4-l10n[-minimal]
!<kde-apps/kdepim-l10n-${PV}
!<kde-apps/ktp-l10n-${PV}
"

KEYWORDS="~amd64 ~x86"
IUSE=""

# /usr/portage/distfiles $ ls -1 kde-l10n-*-${PV}.* |sed -e 's:-${PV}.tar.xz::' -e 's:kde-l10n-::' |tr '\n' ' '
MY_LANGS="ar bg bs ca ca@valencia cs da de el en_GB eo es et eu fa fi fr ga gl
he hi hr hu ia id is it ja kk km ko lt lv mr nb nds nl nn pa pl pt pt_BR ro ru
sk sl sr sv tr ug uk wa zh_CN zh_TW"

URI_BASE="${SRC_URI/-${PV}.tar.xz/}"
SRC_URI=""

for MY_LANG in ${MY_LANGS} ; do
IUSE="${IUSE} linguas_${MY_LANG}"
SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.xz )"
done

S="${WORKDIR}"

src_unpack() {
if [[ -z ${A} ]]; then
elog
elog "You either have the LINGUAS variable unset, or it only"
elog "contains languages not supported by ${P}."
elog "You won't have any additional language support."
elog
elog "${P} supports these language codes:"
elog "${MY_LANGS}"
elog
fi

[[ -n ${A} ]] && unpack ${A}
}

src_prepare() {
local LNG DIR
# add all linguas to cmake
if [[ -n ${A} ]]; then
for LNG in ${LINGUAS}; do
DIR="${PN}-${LNG}-${PV}"
if [[ -d "${DIR}" ]] ; then
echo "add_subdirectory( ${DIR} )" >> "${S}"/CMakeLists.txt

# Drop KDE4-based part
sed -e '/add_subdirectory(4)/ s/^/#/'\
-i "${S}"/${DIR}/CMakeLists.txt || die

# Remove kdepim translations (part of kde-apps/kdepim-l10n)
for subdir in kdepim kdepimlibs kdepim-runtime pim; do
find "${S}/${DIR}" -name CMakeLists.txt -type f \
-exec sed -i -e "/add_subdirectory( *${subdir} *)/ s/^/#/" {} +
done

# Remove ktp translations (part of kde-apps/ktp-l10n)
# Drop that hack (and kde-apps/ktp-l10n) after ktp:4 removal
find "${S}"/${DIR}/5/${LNG}/messages/kdenetwork -type f \
\( -name kaccounts*po -o -name kcm_ktp*po -o -name kcmtelepathy*po \
-o -name kded_ktp*po -o -name ktp*po -o -name plasma*ktp*po \) \
-delete

# Handbook optional
sed -e '/KF5DocTools/ s/ REQUIRED//'\
-i "${S}"/${DIR}/5/${LNG}/CMakeLists.txt || die
if ! use handbook ; then
sed -e '/add_subdirectory(docs)/ s/^/#/'\
-i "${S}"/${DIR}/5/${LNG}/CMakeLists.txt || die
fi

# Fix broken LINGUAS=sr (KDE4 leftover)
if [[ ${LNG} = "sr" ]] ; then
sed -e '/add_subdirectory(lokalize)/ s/^/#/'\
-i "${S}"/${DIR}/5/${LNG}/data/kdesdk/CMakeLists.txt || die
fi
fi
done
fi
}

src_configure() {
mycmakeargs=(
$(cmake-utils_use_find_package handbook KF5DocTools)
)
[[ -n ${A} ]] && kde5_src_configure
}

src_compile() {
[[ -n ${A} ]] && kde5_src_compile
}

src_test() {
[[ -n ${A} ]] && kde5_src_test
}

src_install() {
[[ -n ${A} ]] && kde5_src_install
}
54 changes: 54 additions & 0 deletions kde-apps/kde4-l10n/Manifest

Large diffs are not rendered by default.

52 changes: 52 additions & 0 deletions kde-apps/kde4-l10n/files/kde4-l10n-15.11.90-remove-dirs
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Disable any subdirectories listed here. Comments are ignored
# First argument: parent directory
# Second argument: which subdirectory to disable in CMakeLists.txt
# kde-l10n 5
data/kdeedu khangman
docs/applications kate
docs/applications konsole
docs/applications kwrite
docs/kdeedu kig
docs/kdeedu pairseditor
docs/kdeedu parley
docs/kdeedu step
docs/kdegames bomber
docs/kdegraphics gwenview
docs/kdegraphics kruler
docs/kdesdk kapptemplate
docs/kdesdk okteta
docs/kdeutils kwalletmanager
# Plasma 5.3
docs/kde-runtime fundamentals
docs/kde-runtime kdesu
docs/kde-runtime khelpcenter
docs/kde-runtime knetattach
docs/kde-runtime onlinehelp
docs/kde-runtime/kcontrol bookmarks
docs/kde-runtime/kcontrol cookies
docs/kde-runtime/kcontrol ebrowsing
docs/kde-runtime/kcontrol emoticons
docs/kde-runtime/kcontrol icons
docs/kde-runtime/kcontrol kcmcgi
docs/kde-runtime/kcontrol khtml
docs/kde-runtime/kcontrol smb
docs/kde-runtime/kcontrol trash
docs/kde-runtime/kcontrol useragent
docs/kde-workspace kfontview
docs/kde-workspace kinfocenter
docs/kde-workspace klipper
docs/kde-workspace kmenuedit
docs/kde-workspace ksysguard
docs/kde-workspace plasma-desktop
docs/kde-workspace systemsettings
docs/kde-workspace/kcontrol clock
docs/kde-workspace/kcontrol colors
docs/kde-workspace/kcontrol desktopthemedetails
docs/kde-workspace/kcontrol joystick
docs/kde-workspace/kcontrol kcmaccess
docs/kde-workspace/kcontrol kcmstyle
docs/kde-workspace/kcontrol solid-actions
docs/kde-workspace/kcontrol splashscreen
# kdepim-l10n 5
docs kdepim
docs kdepimlibs
157 changes: 157 additions & 0 deletions kde-apps/kde4-l10n/kde4-l10n-15.12.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,157 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

KDE_HANDBOOK="optional"
KMNAME="kde-l10n"
inherit kde4-base

DESCRIPTION="KDE internationalization package"
HOMEPAGE="http://l10n.kde.org"

DEPEND="
sys-devel/gettext
"
RDEPEND="
!<kde-apps/kde-l10n-${PV}
"

KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="minimal"

REMOVE_DIRS="${FILESDIR}/${PN}-15.11.90-remove-dirs"
REMOVE_MSGS="${FILESDIR}/${PN}-15.08.3-r1-remove-messages"

LV="4.14.3"
LEGACY_LANGS="ar bg bs ca ca@valencia cs da de el en_GB es et eu fa fi fr ga gl
he hi hr hu ia id is it ja kk km ko lt lv mr nb nds nl nn pa pl pt pt_BR ro ru
sk sl sr sv tr ug uk wa zh_CN zh_TW"

# /usr/portage/distfiles $ ls -1 kde-l10n-*-${PV}.* |sed -e 's:-${PV}.tar.xz::' -e 's:kde-l10n-::' |tr '\n' ' '
MY_LANGS="ar bg bs ca ca@valencia cs da de el en_GB eo es et eu fa fi fr ga gl
he hi hr hu ia id is it ja kk km ko lt lv mr nb nds nl nn pa pl pt pt_BR ro ru
sk sl sr sv tr ug uk wa zh_CN zh_TW"

URI_BASE="${SRC_URI/-${PV}.tar.xz/}"
LURI_BASE="mirror://kde/stable/${LV}/src/${KMNAME}"
SRC_URI=""

for MY_LANG in ${LEGACY_LANGS} ; do
IUSE="${IUSE} linguas_${MY_LANG}"
SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${LURI_BASE}/${KMNAME}-${MY_LANG}-${LV}.tar.xz )"
done

for MY_LANG in ${MY_LANGS} ; do
IUSE="${IUSE} linguas_${MY_LANG}"
SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${KMNAME}-${MY_LANG}-${PV}.tar.xz )"
done

S="${WORKDIR}"

src_unpack() {
if [[ -z ${A} ]]; then
elog
elog "You either have the LINGUAS variable unset, or it only"
elog "contains languages not supported by ${P}."
elog "You won't have any additional language support."
elog
elog "${P} supports these language codes:"
elog "${MY_LANGS}"
elog
fi

[[ -n ${A} ]] && unpack ${A}
}

src_prepare() {
local LNG DIR LDIR SDIR
# add all linguas to cmake
if [[ -n ${A} ]]; then
for LNG in ${LINGUAS}; do
DIR="${KMNAME}-${LNG}-${PV}"
LDIR="${KMNAME}-${LNG}-${LV}"
SDIR="${S}/${DIR}/4/${LNG}"
if [[ -d "${DIR}" ]] ; then
echo "add_subdirectory( ${DIR} )" >> "${S}"/CMakeLists.txt

# Drop KF5-based part
sed -e '/add_subdirectory(5)/ s/^/#/' -i "${S}"/${DIR}/CMakeLists.txt

# Drop translations installed with plasma 5 and kde-apps 5 packages
if use minimal; then
einfo "${LNG}: Removing file conflicts"
if [[ -d "${LDIR}" ]] ; then
rm -rf "${LDIR}"
fi

einfo " directories..."
while read path; do
if [[ -n ${path} && -e "${SDIR}"/${path%\ *}/CMakeLists.txt ]] ; then
sed -e ":${path#*\ }: s:^:#:"\
-i "${SDIR}"/${path%\ *}/CMakeLists.txt
fi
done < <(grep -v "^#" "${REMOVE_DIRS}")

einfo " messages..."
for path in $(grep -v "^#" "${REMOVE_MSGS}") ; do
rm -f "${SDIR}"/messages/${path}
# Quirk for LINGUAS=sr variants
if [[ ${LNG} = "sr" ]] ; then
rm -f "${SDIR}"/${LNG}\@*/messages/${path} || die
fi
done
else
if [[ -d "${LDIR}" ]] ; then
einfo "${LNG}: Adding legacy localisation"
local dest_path
# Step through directories alphabetically first
for path in $(ls -R "${LDIR}" | grep ":$" | sed -e 's/:$//') ; do
dest_path="${path/${LV}/${PV}/4/${LNG}}"
if [[ ! -d "${dest_path}" ]] ; then
einfo " $(basename ${dest_path}) subdirectory"\
"added to $(basename $(dirname ${dest_path}))"
mkdir "${dest_path}" || die "Failed creating ${dest_path}"
echo "add_subdirectory($(basename ${dest_path}))" >> \
$(dirname "${dest_path}")/CMakeLists.txt
fi
done
einfo " merging legacy localisation..."
for path in $(find "${LDIR}" -type f) ; do
dest_path="${path/${LV}/${PV}/4/${LNG}}"
cp -rn "${path}" "${dest_path}" || die "Failed copying ${path}"
done
# Disable kdepim
for path in kdepim kdepimlibs kdepim-runtime ; do
find "${SDIR}" -name CMakeLists.txt -type f -exec \
sed -i -e "s:^ *add_subdirectory( *${path} *):# no ${path}:g" {} +
done
rm -rf "${LDIR}"
fi
fi
fi
done
fi

kde4-base_src_prepare
}

src_configure() {
mycmakeargs=(
$(cmake-utils_use_build handbook docs)
)
[[ -n ${A} ]] && kde4-base_src_configure
}

src_compile() {
[[ -n ${A} ]] && kde4-base_src_compile
}

src_test() {
[[ -n ${A} ]] && kde4-base_src_test
}

src_install() {
[[ -n ${A} ]] && kde4-base_src_install
}
Loading

0 comments on commit 1b54bdf

Please sign in to comment.