Skip to content

Commit

Permalink
dev-lua/lanes: migrate to lua eclass
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/752606
Package-Manager: Portage-3.0.9, Repoman-3.0.2
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
ConiKost committed Nov 30, 2020
1 parent a9d2d19 commit 1bf5ae8
Show file tree
Hide file tree
Showing 3 changed files with 92 additions and 0 deletions.
87 changes: 87 additions & 0 deletions dev-lua/lanes/lanes-3.13.0-r100.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,87 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

LUA_COMPAT=( lua5-{1..3} luajit )

inherit lua toolchain-funcs

DESCRIPTION="Lightweight, native, lazy evaluating multithreading library"
HOMEPAGE="https://github.com/LuaLanes/lanes"
SRC_URI="https://github.com/LuaLanes/lanes/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="test"
REQUIRED_USE="${LUA_REQUIRED_USE}"
RESTRICT="!test? ( test )"

RDEPEND="${LUA_DEPS}"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
test? ( ${RDEPEND} )
"

HTML_DOCS=( "docs/." )

PATCHES=( "${FILESDIR}/${PN}-3.13.0-makefile.patch" )

src_prepare() {
default

lua_copy_sources
}

lua_src_compile() {
pushd "${BUILD_DIR}" || die

local myemakeargs=(
"CC=$(tc-getCC)"
"LUA=${ELUA}"
"LUA_FLAGS=$(lua_get_CFLAGS)"
"LUA_LIBS="
"OPT_FLAGS=${CFLAGS}"
)

emake "${myemakeargs[@]}"

popd
}

src_compile() {
lua_foreach_impl lua_src_compile
}

lua_src_test() {
pushd "${BUILD_DIR}" || die

emake LUA="${ELUA}" test

popd
}

src_test() {
lua_foreach_impl lua_src_test
}

lua_src_install() {
pushd "${BUILD_DIR}" || die

local myemakeargs=(
"LUA_LIBDIR=${ED}/$(lua_get_cmod_dir)"
"LUA_SHAREDIR=${ED}/$(lua_get_lmod_dir)"
)

emake "${myemakeargs[@]}" install

popd
}

src_install() {
lua_foreach_impl lua_src_install

einstalldocs
}
4 changes: 4 additions & 0 deletions dev-lua/lanes/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -5,6 +5,10 @@
<email>[email protected]</email>
<name>William Hubbs</name>
</maintainer>
<maintainer type="person">
<email>[email protected]</email>
<name>Conrad Kostecki</name>
</maintainer>
<upstream>
<remote-id type="github">LuaLanes/lanes</remote-id>
</upstream>
Expand Down
1 change: 1 addition & 0 deletions profiles/package.mask
Original file line number Diff line number Diff line change
Expand Up @@ -524,6 +524,7 @@ dev-lua/luacrypto
>=dev-lua/busted-htest-1.0.0-r100
>=dev-lua/dkjson-2.5-r100
>=dev-lua/inifile-1.0-r100
>=dev-lua/lanes-3.13.0-r100
>=dev-lua/ldoc-1.4.6-r100
>=dev-lua/lgi-0.9.2-r100
>=dev-lua/lpeg-1.0.2-r100
Expand Down

0 comments on commit 1bf5ae8

Please sign in to comment.