Skip to content

Commit

Permalink
dev-embedded/u-boot-tools: version bump to 2016.11
Browse files Browse the repository at this point in the history
  • Loading branch information
radhermit committed Dec 12, 2016
1 parent 91c3361 commit 1c343c1
Show file tree
Hide file tree
Showing 2 changed files with 45 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-embedded/u-boot-tools/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST u-boot-2016.03.tar.bz2 11076762 SHA256 e49337262ecac44dbdeac140f2c6ebd1eba345e0162b0464172e7f05583ed7bb SHA512 d3a8d5f334a1a1a33756d9ac33d14eca689cafe1ada478e61b51dcbff1781266d4f0ea121e25d0232b292475721c04be63e5a153715b91a14dfc82656a54de6f WHIRLPOOL 32f246e3bdb71648f47a4246602b6f27de5dbae9834aed71880c5d5e737dfd63adcd03e9b47874b4fa61c0336fe13b8b079693baec633bd428d991abb47a88f0
DIST u-boot-2016.07.tar.bz2 11506848 SHA256 974fb7225c0af6a721307631f66b81e20dbda82a4d7cc32aba2a625727231253 SHA512 fa76dbd7e654ff9e4b3166162be6c0a77ecf2eb2a952b4865df3c818ebcdca7e2bb75e5ba19bf0346000c3d185888552193bb74510b115426cfe444b78efd3ef WHIRLPOOL 066019af0e8fd04d53569ebd001309238514daa757be6cc50db6d4544f34d0c720ff420811d44d88af6028d02dfb02667e44d8d1abb23bb364baff46c5a26a9f
DIST u-boot-2016.09.01.tar.bz2 11783287 SHA256 95728e89dd476d17428f94080752ab48884be477b6a678941582aeef618b70bb SHA512 aa503acb1ce4f64a936fbc1292e80c54fe334fcfb1a0da412a755f9a56a24993178ad1a5b8a51f777388d8ce5a62b0626bb5fead503f9b118f7d9f3f1a7c07b7 WHIRLPOOL 35b6ecedcdf99eabfddc90157b1998be1732fbdf46b4ca1221f8fb95e47d6e5fce7725d6b72d04b973f05267b31b3fd9d9beadba9d77e3d4dfc1c0b09d396957
DIST u-boot-2016.11.tar.bz2 12019669 SHA256 45813e6565dcc0436abe6752624324cdbf5f3ac106570d76d32b46ec529bcdc8 SHA512 d393b2aa4114a6de7f990efe370891376c934a1cfac9530c3bc44f988e7f2c9f0ec26653e3275c72a0a1c2f4b44fcd0afe8394c9ae3ca93fee1c689d870c063d WHIRLPOOL f9a7837cac2b7b4e1395350a9670e438396818bcb80baebbb9a65ebe739914319fa3e076c288bb3f10ffad0f954336a6a18ea5611824f7f05d7a1518bb65cdad
44 changes: 44 additions & 0 deletions dev-embedded/u-boot-tools/u-boot-tools-2016.11.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit toolchain-funcs

MY_P="u-boot-${PV/_/-}"
DESCRIPTION="utilities for working with Das U-Boot"
HOMEPAGE="http://www.denx.de/wiki/U-Boot/WebHome"
SRC_URI="ftp://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE=""

S=${WORKDIR}/${MY_P}

src_compile() {
# Unset a few KBUILD variables. Bug #540476
unset KBUILD_OUTPUT KBUILD_SRC
emake defconfig
emake \
HOSTSTRIP=: \
STRIP=: \
HOSTCC="$(tc-getCC)" \
HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
HOSTLDFLAGS="${LDFLAGS}" \
CONFIG_ENV_OVERWRITE=y \
tools-all
}

src_install() {
cd tools || die
dobin bmp_logo dumpimage fdtgrep gen_eth_addr img2srec mkenvimage mkimage
dobin easylogo/easylogo
dobin env/fw_printenv
dosym fw_printenv /usr/bin/fw_setenv
insinto /etc
doins env/fw_env.config
doman "${S}"/doc/mkimage.1
}

0 comments on commit 1c343c1

Please sign in to comment.