Skip to content

Commit

Permalink
app-doc/gnucash-docs: Bump to 3.3
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Signed-off-by: Aaron Swenson <[email protected]>
  • Loading branch information
titanofold committed Oct 3, 2018
1 parent 9d6096a commit 1ed1e59
Show file tree
Hide file tree
Showing 2 changed files with 86 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-doc/gnucash-docs/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST gnucash-docs-3.0.tar.gz 92420576 BLAKE2B 95d8c310b3616b44a814c7c5d6e8b1b586eef12831ea967818bef302e0dde3f0ab8e1b1d4fd0d504173625d87d54738a392ad3d53b8bfa079fd5ba87ac3a2d91 SHA512 908694725de6d9595cb73d4b334f157287a864ff7ba1057bdff7c0fb55660c5828a6b5c1e868eea7fbd0fca4b3b594fb3989092f270446dbd56c07479c6036cf
DIST gnucash-docs-3.1.tar.gz 92421041 BLAKE2B b169d26cb9fb07a265fb5b8fc492fa8b0ed240be094278416d54542dd4ca074b3d4a182421b75d09c1f6c435891c5637aed646f0d11bdd57a9b71cbc999676dd SHA512 4af1f0b895cc928c109ae4f883efd1b483a5b318e02fcd6ca4ff7631ed4e13bc0f89f28b2f8ea895f9e37f596eb7b84e84732dfac6b2d4fe98b7405603149339
DIST gnucash-docs-3.2.tar.gz 92387447 BLAKE2B dac502975f885b777c1e91a7ea574789947e1dddfd3239c05973ce57fec41a6d78e605ef37aaf721db4aa4d2bc8f2dda7ed76cc4dc97dd49e30618414e262f15 SHA512 a58a583a457377f529223ced083fb64460b3b0c75a423db08c7f9542711be98fd59bd776bf77309ff91d1c46f22a5ae882d8c0a8ec3fc834d7a8028a95028aad
DIST gnucash-docs-3.3.tar.gz 92417386 BLAKE2B 200f9b8d3006589eac5f0d66300d658f69f5c55078371c5b416e34784835350de9bd40fc5d85e59116022874294f74e259a034d6ebcaf315b1ea9942b8350c7b SHA512 5887171cbe95f545eb6e647aee2d04a26ab9102643acd8d3e5754000613a7fb08e4470777f7dfbfd0d1ed7609de7a6241cd82f5c7d62f632b2e3751b005bc01e
85 changes: 85 additions & 0 deletions app-doc/gnucash-docs/gnucash-docs-3.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,85 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PLOCALES="C de it ja pt ru"
PLOCALE_BACKUP="C"

inherit autotools gnome2 l10n

DESCRIPTION="Documentation package for GnuCash"
HOMEPAGE="http://www.gnucash.org/"
SRC_URI="https://github.com/Gnucash/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

SLOT="0"
LICENSE="GPL-2 FDL-1.1"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"

for my_locale in ${PLOCALES}; do
IUSE+=" l10n_${my_locale}"
done

DEPEND="
app-text/docbook-xml-dtd
app-text/docbook-xsl-stylesheets
app-text/rarian
dev-libs/libxml2
dev-libs/libxslt
"

my_l10n_get_locales() {
local l locales
for l in ${PLOCALES[@]}; do
use "l10n_${l}" && locales+=( $l )
done
if [[ ${#locales[@]} -gt 0 ]]; then
echo ${locales[@]}
else
echo $PLOCALE_BACKUP
fi
}

src_prepare() {
default
eautoreconf
}

src_compile() {
:
}

src_install() {
local doc_type my_lang

for doc_type in help guide; do
for my_lang in $(my_l10n_get_locales); do
case $my_lang in
# Both help and guides translated
C|de|it|pt) ;;
ru|ja) # Only guides translated
if [[ ${doc_type} = "help" ]] ; then
elog "Help documentation hasn't been translated for $my_lang"
elog "Will do English instead."
my_lang=C
fi
;;
*)
die "Invalid locale: $my_lang"
;;
esac

cd "${S}/${doc_type}/${my_lang}" || die
emake DESTDIR="${D}" install
done
done

cd "${S}" || die
einstalldocs
}

pkg_postinst() {
gnome2_pkg_postinst
optfeature "You need dev-java/fop to generate pdf files." dev-java/fop
optfeature "You need gnome-extra/yelp to view the docs." gnome-extra/yelp
}

0 comments on commit 1ed1e59

Please sign in to comment.