Skip to content

Commit

Permalink
games-board/pokerth: Fully qualify std::advance
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/show_bug.cgi?id=629966
Package-Manager: Portage-2.3.8, Repoman-2.3.3
  • Loading branch information
SoapGentoo committed Sep 7, 2017
1 parent b7eb4cc commit 1f6eeb3
Show file tree
Hide file tree
Showing 2 changed files with 19 additions and 4 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
Boost 1.65 made 'advance()' ambiguous.
Bug: https://bugs.gentoo.org/show_bug.cgi?id=629966

--- a/src/gui/qt/gametable/gametableimpl.cpp
+++ b/src/gui/qt/gametable/gametableimpl.cpp
@@ -3859,7 +3859,7 @@
int playerCount = static_cast<int>(seatList->size());
if (id < playerCount) {
PlayerListIterator pos = seatList->begin();
- advance(pos, id);
+ std::advance(pos, id);
myStartWindow->getSession()->startVoteKickPlayer((*pos)->getMyUniqueID());
}
}
9 changes: 5 additions & 4 deletions games-board/pokerth/pokerth-1.1.1-r2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -38,10 +38,11 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}

PATCHES=(
"${FILESDIR}/${P}-qt5.patch"
"${FILESDIR}/${P}-boost-1.60.patch"
"${FILESDIR}/${P}-qmake-gcc-6.patch"
"${FILESDIR}/${P}-boost-noexcept.patch"
"${FILESDIR}"/${PN}-1.1.1-qt5.patch
"${FILESDIR}"/${PN}-1.1.1-boost-1.60.patch
"${FILESDIR}"/${PN}-1.1.1-qmake-gcc-6.patch
"${FILESDIR}"/${PN}-1.1.1-boost-noexcept.patch
"${FILESDIR}"/${PN}-1.1.1-boost-1.65-ambiguous-advance.patch
)

src_prepare() {
Expand Down

0 comments on commit 1f6eeb3

Please sign in to comment.