Skip to content

Commit

Permalink
app-backup/dar: Bump to version 2.6.4
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.67, Repoman-2.3.12
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed May 26, 2019
1 parent 4b2ec9c commit 1f8d055
Show file tree
Hide file tree
Showing 2 changed files with 107 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-backup/dar/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST dar-2.5.11.tar.gz 1891928 BLAKE2B 536cccca2533f7ddbc8b95972fe00e9c87a404481
DIST dar-2.5.18.tar.gz 1931746 BLAKE2B 3d47665a1ab955ab9467d8f10a686565c549e1be57e77a9bcf65f1ea25c9b70d6d148d4b9dc35112b3ca74f9df05505c74e3a7eaa211b6a8b466308121206a2f SHA512 cde787bb4c3a3a1014efdb5e437b963d762eb87c512e1de1d60471035c535965e03adb5f75abc2bc95633bb6fb61226027d836a87fc903995e3a27a540632e69
DIST dar-2.6.2.tar.gz 2100192 BLAKE2B 1eb2f92e5162070a75182741f850e79932593f68fd1f31a4a1d19af77c6f86df0c8e5b995b5ccd265f051891827bfa89bf71832cb7ce6f97d9ab70e768c867b4 SHA512 88f128f99a3fe22866056e2fc881276c13731004e40437f9e2c363c4e24f603ab5b9fe7126e4f950526ccfc1b6f86fe1a4494036e83e1faf9a647ce239293ea4
DIST dar-2.6.3.tar.gz 2110304 BLAKE2B 638bf949066c7c59e139f7a4d54d427dd86eb7d254f0cfff3cc977d75abb17d1c69d37018c46a9fab9be38193e758fd70d1598c32a98bb6f0006f97c356a4ff6 SHA512 3e3e1fa92a6954ac745dce9ecd4e82589bde562760f6cd5402fae9250f84e2df4784672ae9b0c4fa0e0baf5b2b642a025fa694a5975a5346e890655b65d93783
DIST dar-2.6.4.tar.gz 2110571 BLAKE2B 769fd08d72e3a33066749ea8c93cd7eec8091796343f27eb991e751843ccad440afe5e24e54e148865da64764d465e1a4a057005a80f9dcf103f0c960c295669 SHA512 ba78936e645cc06f94e64bf0e288398ee522b4be6c3501f9b21d7038d7a66a083386c7520aaaddd265de68937d017dcb2fd87bf06f3e2a91f444f3307b4c15b9
106 changes: 106 additions & 0 deletions app-backup/dar/dar-2.6.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,106 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit flag-o-matic

DESCRIPTION="A full featured backup tool, aimed for disks"
HOMEPAGE="http://dar.linux.free.fr/"
SRC_URI="mirror://sourceforge/dar/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux"
IUSE="curl dar32 dar64 doc gcrypt gpg lzo nls static static-libs xattr"

RESTRICT="test" # need to be run as root

RDEPEND=">=sys-libs/zlib-1.2.3:=
!static? (
app-arch/bzip2:=
app-arch/xz-utils:=
sys-libs/libcap
curl? ( net-misc/curl )
gcrypt? ( dev-libs/libgcrypt:0= )
gpg? ( app-crypt/gpgme )
lzo? ( dev-libs/lzo:= )
xattr? ( sys-apps/attr:= )
)"

DEPEND="${RDEPEND}
static? (
app-arch/bzip2[static-libs]
app-arch/xz-utils[static-libs]
sys-libs/libcap[static-libs]
sys-libs/zlib[static-libs]
curl? ( net-misc/curl[static-libs] )
gcrypt? ( dev-libs/libgcrypt:0=[static-libs] )
gpg? (
app-crypt/gpgme[static-libs]
dev-libs/libassuan[static-libs]
dev-libs/libgpg-error[static-libs]
)
lzo? ( dev-libs/lzo[static-libs] )
xattr? ( sys-apps/attr[static-libs] )
)
"
BDEPEND="
nls? (
sys-devel/gettext
virtual/libintl
)
doc? ( app-doc/doxygen )
"

REQUIRED_USE="?? ( dar32 dar64 )
gpg? ( gcrypt )"

#PATCHES=(
#)

src_configure() {
# configure.ac is totally funked up regarding the AC_ARG_ENABLE
# logic.
# For example "--enable-dar-static" causes configure to DISABLE
# static builds of dar.
# Do _not_ use $(use_enable) until you have verified that the
# logic has been fixed by upstream.
local myconf=(
--disable-upx
$(usex curl '' --disable-libcurl-linking)
$(usex dar32 --enable-mode=32 '')
$(usex dar64 --enable-mode=64 '')
$(usex doc '' --disable-build-html)
#$(usex examples --enable-examples '')
$(usex gcrypt '' --disable-libgcrypt-linking)
$(usex gpg '' --disable-gpgme-linking)
$(usex lzo '' --disable-liblzo2-linking)
$(usex nls '' --disable-nls)
#$(usex rsync '' --disable-librsync-linking)
$(usex xattr '' --disable-ea-support)
)

# Bug 103741
filter-flags -fomit-frame-pointer

if ! use static ; then
myconf+=( --disable-dar-static )
if ! use static-libs ; then
myconf+=( --disable-static )
fi
fi

econf ${myconf[@]}
}

src_install() {
emake DESTDIR="${D}" pkgdatadir="${EPREFIX}"/usr/share/doc/${PF}/html install

local DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
einstalldocs

find "${ED}" -name '*.la' -delete || die
if ! use static-libs ; then
find "${ED}" -name '*.a' -delete || die
fi
}

0 comments on commit 1f8d055

Please sign in to comment.