Skip to content

Commit

Permalink
games-engines/stratagus: Bump to 2.4.3
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Nov 22, 2020
1 parent d3f83d5 commit 205c0fa
Show file tree
Hide file tree
Showing 3 changed files with 65 additions and 2 deletions.
1 change: 1 addition & 0 deletions games-engines/stratagus/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST stratagus-2.4.1.tar.gz 1087678 BLAKE2B be7fc8322aee2a28c80833d44c3180e26b961ce9dfd1bc5e0a8e3fa0caac74bf713224de4c38b2ebf6d5aeabbe778a5664346c6a444b066f07f719bba5317bac SHA512 1f0420677df72e3e2d2f31e60030fa2eba4c3d1ab80cfc79c045724fe39ac237846bc38e8762ee9aa51768a443cdbbaa1fe91bf80fb2164261288a1bb17e27cd
DIST stratagus-2.4.3.tar.gz 1123537 BLAKE2B 90e40b2b277b5c52977f3c0ae2ae8f2e65d940d765e2ca4f7def4f8cf903399350f5e46f6dc6fbc38f3a53c7ca9ecaf5cf38025ec69154972869f28da37865d4 SHA512 16271c4fed3fb75fb8fb08e363e72713ede7979ea7e25b7c83db2fa9a0688fb7927cad3379e3b23e172c409cf0f6db18f7c6557d19a693c9a7f24109b56d2a56
3 changes: 1 addition & 2 deletions games-engines/stratagus/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -13,7 +13,6 @@
<flag name="fluidsynth">compile with support for fluidsynth</flag>
</use>
<upstream>
<remote-id type="launchpad">stratagus</remote-id>
<remote-id type="sourceforge">stratagus</remote-id>
<remote-id type="github">Wargus/stratagus</remote-id>
</upstream>
</pkgmetadata>
63 changes: 63 additions & 0 deletions games-engines/stratagus/stratagus-2.4.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit cmake

DESCRIPTION="A realtime strategy game engine"
HOMEPAGE="https://wargus.github.io/stratagus.html
https://github.com/Wargus/stratagus"
SRC_URI="https://github.com/Wargus/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="bzip2 debug doc fluidsynth mikmod mng theora vorbis"
REQUIRED_USE="theora? ( vorbis )"

RDEPEND="
dev-db/sqlite:3
>=dev-lang/lua-5:0
dev-lua/toluapp
media-libs/libpng:0
virtual/opengl
x11-libs/libX11
media-libs/libsdl[sound,opengl,video]
sys-libs/zlib
bzip2? ( app-arch/bzip2 )
fluidsynth? ( media-sound/fluidsynth )
mikmod? ( media-libs/libmikmod )
mng? ( media-libs/libmng )
vorbis? (
media-libs/libogg
media-libs/libvorbis
theora? ( media-libs/libtheora )
)"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
doc? ( app-doc/doxygen )"

PATCHES=(
"${FILESDIR}/${PN}"-2.3.0-doc.patch
)

src_configure() {
# there are in-source switches
use debug && CMAKE_BUILD_TYPE=Debug

local mycmakeargs=(
-DGAMEDIR="/usr/bin"
-DDOCDIR="/usr/share/doc/${PF}"
-DWITH_BZIP2=$(usex bzip2)
-DWITH_FLUIDSYNTH=$(usex fluidsynth)
-DWITH_MIKMOD=$(usex mikmod)
-DWITH_MNG=$(usex mng)
-DWITH_OGGVORBIS=$(usex vorbis)
-DWITH_THEORA=$(usex theora)
-DENABLE_DOC=$(usex doc)
-DENABLE_DEV=ON
)

cmake_src_configure
}

0 comments on commit 205c0fa

Please sign in to comment.