Skip to content

Commit

Permalink
dev-tex/minted: fix compilation of documentation
Browse files Browse the repository at this point in the history
Compiling of documentation currently failed, as -shell-escape was not
passed to pdflatex. With recent change in latex-package.eclass
(f6082c5) it is now possible to add this flag and therefore compile the
documentation.
Moreover in minted-2.1 there is an extra curly brace in minted.dtx which
leads to a compile failure also with -shell-escape specified. Until it
is fixed upstream, I added a patch to remove this extra curly brace.

Closes: gentoo#986
Acked-by: Alexis Ballier <[email protected]>
Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
nonapode authored and monsieurp committed Mar 11, 2016
1 parent c27731d commit 2083a93
Show file tree
Hide file tree
Showing 4 changed files with 23 additions and 1 deletion.
15 changes: 15 additions & 0 deletions dev-tex/minted/files/minted-2.1-remove-extra-curly-brace.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
# compilation of minted.dtx fails as there is an extra curly brace at line
# 1390. While passing -interaction=batchmode (what latex-package.eclass does)
# it compiles without warning but a return value of -1 and therefore is assumed
# as failed by latex-package.eclass.
--- minted.dtx 2015-09-09 22:40:04.000000000 +0200
+++ minted.dtx 2016-03-06 14:20:46.544180149 +0100
@@ -1387,7 +1387,7 @@
%
%
% \begin{macro}{\minted@jobname}
-% At various points, temporary files and directories will need to be named after the main |.tex| file. The typical way to do this is to use |\jobname|. However, if the file name contains spaces, then |\jobname| will contain the name wrapped in quotes (older versions of MiKTeX replace spaces with asterisks instead, and \texttt{XeTeX} apparently \href{http://tex.stackexchange.com/a/93829/10742}{allows double quotes within file names}, in which case names are wrapped in single quotes}). While that is perfectly fine for working with \LaTeX\ internally, it causes problems with |\write18|, since quotes will end up in unwanted locations in shell commands. It would be possible to strip the wrapping quotation marks when they are present, and maintain any spaces in the file name. But it is simplest to create a ``sanitized'' version of |\jobname| in which spaces and asterisks are replaced by underscores, and double quotes are stripped.
+% At various points, temporary files and directories will need to be named after the main |.tex| file. The typical way to do this is to use |\jobname|. However, if the file name contains spaces, then |\jobname| will contain the name wrapped in quotes (older versions of MiKTeX replace spaces with asterisks instead, and \texttt{XeTeX} apparently \href{http://tex.stackexchange.com/a/93829/10742}{allows double quotes within file names}, in which case names are wrapped in single quotes). While that is perfectly fine for working with \LaTeX\ internally, it causes problems with |\write18|, since quotes will end up in unwanted locations in shell commands. It would be possible to strip the wrapping quotation marks when they are present, and maintain any spaces in the file name. But it is simplest to create a ``sanitized'' version of |\jobname| in which spaces and asterisks are replaced by underscores, and double quotes are stripped.
% \begin{macrocode}
\StrSubstitute{\jobname}{ }{_}[\minted@jobname]
\StrSubstitute{\minted@jobname}{*}{_}[\minted@jobname]
1 change: 1 addition & 0 deletions dev-tex/minted/minted-1.7.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -23,6 +23,7 @@ RDEPEND="
S="${WORKDIR}"/

src_install() {
LATEX_DOC_ARGUMENTS='-shell-escape'
latex-package_src_install
dodoc README
}
1 change: 1 addition & 0 deletions dev-tex/minted/minted-2.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -23,6 +23,7 @@ RDEPEND="
S="${WORKDIR}"/${P}/source

src_install() {
LATEX_DOC_ARGUMENTS='-shell-escape'
latex-package_src_install
dodoc "${S}"/../*md
}
7 changes: 6 additions & 1 deletion dev-tex/minted/minted-2.1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@

EAPI=5

inherit latex-package
inherit latex-package eutils

DESCRIPTION="LaTeX package for source code syntax highlighting"
HOMEPAGE="https://github.com/gpoore/minted"
Expand All @@ -22,7 +22,12 @@ RDEPEND="

S="${WORKDIR}"/${P}/source

src_prepare() {
epatch "${FILESDIR}/minted-2.1-remove-extra-curly-brace.patch"
}

src_install() {
LATEX_DOC_ARGUMENTS='-shell-escape'
latex-package_src_install
dodoc "${S}"/../*md
}

0 comments on commit 2083a93

Please sign in to comment.