Skip to content

Commit

Permalink
app-admin/sysstat: Version bump.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
Jeroen Roovers committed Mar 1, 2017
1 parent 5079b5b commit 209d431
Show file tree
Hide file tree
Showing 2 changed files with 90 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/sysstat/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST sysstat-11.4.2.tar.xz 344168 SHA256 1fd407f8971f5854bc853d931dd85bcbea08658
DIST sysstat-11.4.3.tar.xz 344572 SHA256 02e9cafa5557fbae435d33e592373655df929d817ae711d31142dd2f7d4dcee7 SHA512 20862a6fd735aa0a6d571ffe0e1aa755ce9c5d8a704739f0095d19861394ea3a45c93e9f46ac5f42b6719ba1aa21e33261ac28fde643d7f5c315d7f0a7b0d74d WHIRLPOOL 64df9bf1a375ce7ebf727b07b10caa3b72ba3630a5a238e72dca017e09a65dbf3f1623f5e1115fb037974609e39c4fb4e3f2790c444b23eae4fb7af591bfd389
DIST sysstat-11.5.3.tar.xz 350468 SHA256 f8229d14819e2d461ede83894648e03c8a2ad14a1ba200d68cda9816c42f41ea SHA512 41af196dec7b13e2496ae0a59ec5dfb4da7e996ee38ac633964460dcc8c008f16af7524c79d770a197662add6821b8b60de2b118507e06f0ccb84280aee13cb0 WHIRLPOOL ae8737af473fab427e7710406c207e57526e476915b5bfe19bb8043bf8038da5f887d5a1f99d9270fd4074d7d9c58745a5a397f814ae544396447f7d42b10302
DIST sysstat-11.5.4.tar.xz 356996 SHA256 1e1008656575e70486b456e79775e98d3b8732d7e2cb408559209bd0318e0807 SHA512 323c6239dadb0608aae0a98407a61ef5a3ef25f181b5442e285fa77c787fafb7a650936d48a5f4e45caabed76e657d956d28a5bc7a53e8f9a607793ed7c0f3f5 WHIRLPOOL 451d2de3adf631183aa28c6c6c4bd99f49ca537412bf5e532edcee8e4d4f470eb69cfab6df2ca20bdb1e9d2c9cebcd2cc23ed0f695f65d4440e91c4785502fae
DIST sysstat-11.5.5.tar.xz 463656 SHA256 f4c5b333827cb588df1842d7a8f46947f486c95b305edbbce7565925e88e86c3 SHA512 abf96e10a36fa88de8b1431e9c0ce277fbfc3a5ffe84f96c6a46fb8e8f6a15c626cffd3cecac2e78284385447b22c84af30992118b46984d72947a4bda80c9c0 WHIRLPOOL 294b018284ba7a83a67827df28bed6911ab57bbab2d88f68eb1f0a3ad474ec001c37507e19301adeee4188e8c20fc11d8c8a68504bb2d61cbbe2df32dc8510f7
89 changes: 89 additions & 0 deletions app-admin/sysstat/sysstat-11.5.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,89 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit flag-o-matic multilib systemd toolchain-funcs

DESCRIPTION="System performance tools for Linux"
HOMEPAGE="http://pagesperso-orange.fr/sebastien.godard/"
SRC_URI="${HOMEPAGE}${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
IUSE="debug nls lm_sensors selinux static"

CDEPEND="
nls? ( virtual/libintl )
lm_sensors? ( sys-apps/lm_sensors )
"
DEPEND="
${CDEPEND}
nls? ( sys-devel/gettext )
"
RDEPEND="
${CDEPEND}
selinux? ( sec-policy/selinux-sysstat )
"
PATCHES=(
"${FILESDIR}"/${PN}-10.0.4-flags.patch
"${FILESDIR}"/${PN}-11.0.4-cron.patch
)

SYSSTAT_FAKE_RC_DIR=Gentoo-does-not-use-rc.d

src_prepare() {
if use nls; then
strip-linguas -i nls/
local lingua pofile
for pofile in nls/*.po; do
lingua=${pofile/nls\/}
lingua=${lingua/.po}
if ! has ${lingua} ${LINGUAS}; then
rm "nls/${lingua}.po" || die
fi
done
fi

default
}

src_configure() {
tc-export AR
use static && append-ldflags -static

sa_lib_dir=/usr/$(get_libdir)/sa \
conf_dir=/etc \
rcdir=${SYSSTAT_FAKE_RC_DIR} \
econf \
$(use_enable debug debuginfo) \
$(use_enable lm_sensors sensors) \
$(use_enable nls) \
--enable-copy-only \
--enable-documentation \
--enable-install-cron \
--with-systemdsystemunitdir=$(systemd_get_systemunitdir)
}

src_compile() {
emake LFLAGS="${LDFLAGS}"
}

src_install() {
keepdir /var/log/sa

emake \
CHOWN=true \
DESTDIR="${D}" \
DOC_DIR=/usr/share/doc/${PF} \
MANGRPARG='' \
install

dodoc -r contrib/

rm -r "${D}/${SYSSTAT_FAKE_RC_DIR}" || die
newinitd "${FILESDIR}"/${PN}.init.d ${PN}
systemd_dounit ${PN}.service

rm -f "${D}"usr/share/doc/${PF}/COPYING
}

0 comments on commit 209d431

Please sign in to comment.