Skip to content

Commit

Permalink
sys-libs/llvm-libunwind: Add a live ebuild
Browse files Browse the repository at this point in the history
  • Loading branch information
mgorny committed Sep 2, 2016
1 parent 80d3b80 commit 2113d78
Showing 1 changed file with 36 additions and 0 deletions.
36 changes: 36 additions & 0 deletions sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
CMAKE_MIN_VERSION=3.4.3
inherit cmake-utils git-r3

DESCRIPTION="C++ runtime stack unwinder from LLVM"
HOMEPAGE="https://github.com/llvm-mirror/libunwind"
SRC_URI=""
EGIT_REPO_URI="http://llvm.org/git/libunwind.git
https://github.com/llvm-mirror/libunwind.git"

LICENSE="|| ( UoI-NCSA MIT )"
SLOT="0"
KEYWORDS=""
IUSE="debug +static-libs"

RDEPEND="!sys-libs/libunwind"
# llvm-config and cmake files needed to get proper flags
DEPEND=">=sys-devel/llvm-3.8.1-r2"

src_configure() {
local libdir=$(get_libdir)

local mycmakeargs=(
-DLLVM_LIBDIR_SUFFIX=${libdir#lib}
-DLIBUNWIND_ENABLE_ASSERTIONS=$(usex debug)
-DLIBUNWIND_ENABLE_STATIC=$(usex static-libs)
)

cmake-utils_src_configure
}

0 comments on commit 2113d78

Please sign in to comment.