Skip to content

Commit

Permalink
net-libs/shairplay: fix use flags and dependencies
Browse files Browse the repository at this point in the history
media-libs/libao is always required
net-dns/avahi[mdnsresponder-compat] is a build time dependency
Drop alac use flag; media-sound/alac_decoder is never used
drop tools use flag as tools are not configurable

Closes: https://bugs.gentoo.org/671410
Package-Manager: Portage-2.3.51, Repoman-2.3.12
Signed-off-by: Craig Andrews <[email protected]>
  • Loading branch information
candrews committed Nov 18, 2018
1 parent 575f399 commit 21648ed
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 10 deletions.
49 changes: 49 additions & 0 deletions net-libs/shairplay/shairplay-0_pre20180824-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools

if [[ ${PV} == "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/juhovh/${PN}.git"
else
EGIT_COMMIT="096b61ad14c90169f438e690d096e3fcf87e504e"
SRC_URI="https://github.com/juhovh/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
KEYWORDS="~amd64 ~x86"
fi

DESCRIPTION="Apple airplay and raop protocol server"
HOMEPAGE="https://github.com/juhovh/shairplay"
LICENSE="BSD LGPL-2.1 MIT
playfair? ( GPL-3+ )"

SLOT="0"
IUSE="+playfair static-libs"

DEPEND="
net-dns/avahi[mdnsresponder-compat]
media-libs/libao
"

RDEPEND="
${DEPEND}
"

src_prepare() {
default
eautoreconf
}

src_configure() {
econf \
$(use_with playfair) \
$(use_enable static-libs static)
}

src_install() {
default
find "${D}" -name '*.la' -delete || die
}
14 changes: 4 additions & 10 deletions net-libs/shairplay/shairplay-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -21,21 +21,15 @@ LICENSE="BSD LGPL-2.1 MIT
playfair? ( GPL-3+ )"

SLOT="0"
IUSE="alac +playfair static-libs tools"
IUSE="+playfair static-libs"

DEPEND="
tools? ( media-libs/libao )
net-dns/avahi[mdnsresponder-compat]
media-libs/libao
"

RDEPEND="
alac? (
media-sound/alac_decoder
net-libs/shairplay[tools]
)
tools? (
dev-libs/openssl:0=
net-dns/avahi[mdnsresponder-compat]
)
${DEPEND}
"

src_prepare() {
Expand Down

0 comments on commit 21648ed

Please sign in to comment.