Skip to content

Commit

Permalink
app-editors/gedit-plugins: bump to 3.34.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <[email protected]>
  • Loading branch information
leio committed Mar 22, 2020
1 parent 8e89f95 commit 218a9ce
Show file tree
Hide file tree
Showing 2 changed files with 110 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-editors/gedit-plugins/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gedit-plugins-3.32.2.tar.xz 1474264 BLAKE2B feb116ec201b9eb9630570818cc288f0044ecfc174fc84c7d812aa6dfba5cc3748b4e2351ffa2be0d3a593a58b2318c4296b54b84476fc887195ee27f27bb597 SHA512 2767bc766daba5e1c81ef5a00bc3589a301c02e0286a6622cf11a03b5b391ecbcf9456187563dad4f2916610ee9ddca4414ff4beb639820954385ee3f8091d2a
DIST gedit-plugins-3.34.1.tar.xz 978800 BLAKE2B 03225ddc414e172f08179c64fbf12d0282c131b71855ca9dc20ceaa5750a5555c7bdde8c4ff1d95c721177b3d379edbcfc9af19ec22b96942df1913d13560303 SHA512 7fe31c2b0a1381a44362bd6066422d182b2246e3f903f8cd83cde0467b9853620a445bea7878d93e95a0a71ac5d5dd081a1930d602007cf2a6ef00b1a45bebfc
109 changes: 109 additions & 0 deletions app-editors/gedit-plugins/gedit-plugins-3.34.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,109 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"
PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="xml"
VALA_MIN_API_VERSION="0.28"

inherit gnome.org gnome2-utils meson python-single-r1 vala xdg

DESCRIPTION="Collection of extra plugins for the gedit Text Editor"
HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ShippedPlugins"

LICENSE="GPL-2+"
KEYWORDS="~amd64 ~x86"
SLOT="0"

IUSE="charmap git +python terminal vala"
REQUIRED_USE="
charmap? ( python )
git? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
terminal? ( python )
"

RDEPEND="
>=dev-libs/libpeas-1.14.1[gtk]
>=app-editors/gedit-3.16
>=dev-libs/glib-2.32:2
>=x11-libs/gtk+-3.9:3
>=x11-libs/gtksourceview-4.0.2:4
python? (
${PYTHON_DEPS}
$(python_gen_cond_dep '
>=app-editors/gedit-3.16[introspection,python,${PYTHON_SINGLE_USEDEP}]
dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
>=dev-python/dbus-python-0.82[${PYTHON_MULTI_USEDEP}]
dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
dev-python/pygobject:3[cairo,${PYTHON_MULTI_USEDEP}]
')
>=x11-libs/gtk+-3.9:3[introspection]
>=x11-libs/gtksourceview-4.0.2:4[introspection]
x11-libs/pango[introspection]
x11-libs/gdk-pixbuf:2[introspection]
)
charmap? ( >=gnome-extra/gucharmap-3:2.90[introspection] )
git? ( >=dev-libs/libgit2-glib-0.0.6[python] )
terminal? ( >=x11-libs/vte-0.52:2.91[introspection] )
" # vte-0.52+ for feed_child API compatibility
DEPEND="${RDEPEND}"
BDEPEND="
dev-libs/libxml2
dev-util/itstool
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
vala? ( $(vala_depend) )
"

pkg_setup() {
use python && python-single-r1_pkg_setup
}

src_prepare() {
use vala && vala_src_prepare
xdg_src_prepare
}

src_configure() {
local emesonargs=(
-Dplugin_bookmarks=true
$(meson_use python plugin_bracketcompletion)
$(meson_use charmap plugin_charmap)
$(meson_use python plugin_codecomment)
$(meson_use python plugin_colorpicker)
$(meson_use python plugin_colorschemer)
$(meson_use python plugin_commander)
-Dplugin_drawspaces=true
$(meson_use vala plugin_findinfiles)
$(meson_use git plugin_git)
$(meson_use python plugin_joinlines)
$(meson_use python plugin_multiedit)
$(meson_use python plugin_sessionsaver)
$(meson_use python plugin_smartspaces)
$(meson_use python plugin_synctex)
$(meson_use terminal plugin_terminal)
$(meson_use python plugin_textsize)
$(meson_use python plugin_translate)
-Dplugin_wordcompletion=true
-Dplugin_zeitgeist=false
)
meson_src_configure
}

src_install() {
meson_src_install
python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
}

pkg_postinst() {
xdg_pkg_postinst
gnome2_schemas_update
}

pkg_postrm() {
xdg_pkg_postrm
gnome2_schemas_update
}

0 comments on commit 218a9ce

Please sign in to comment.