Skip to content

Commit

Permalink
net-print/cups-filters: Bump to version 1.16.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.7, Repoman-2.3.3
  • Loading branch information
Lars Wendler committed Aug 14, 2017
1 parent a0242e0 commit 21f0b64
Show file tree
Hide file tree
Showing 2 changed files with 135 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-print/cups-filters/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,4 +2,5 @@ DIST cups-filters-1.13.5.tar.xz 1424764 SHA256 35db1c5821c9ff0e0fedcf87b3ae68a42
DIST cups-filters-1.14.1.tar.xz 1426140 SHA256 f1393731df54ffdd947621c302a66afa17cd3d6c7e107ee05cc77a7d3194e504 SHA512 fcc5ad217fe4c0d2f9377b065fe007589d605f9358ad274881df25176cc9548aa233ee6b6efad544f2b0ea4687b09c4270c5c9ac5014c5bcacc4bd9807b6be4e WHIRLPOOL 1dc45519d22248f5f4710e3692f84168c37cf33aa69d3ab23db8ea6939ffeeade5d0bd6e28674ad7b02017f761b6a691ac1f4515bda829acbbaae0dbfbb5d70d
DIST cups-filters-1.15.0.tar.xz 1433652 SHA256 a3bd793c55636904f8c3756f8fb64866ec4bb533f933250d6e04ebfdfeaad23c SHA512 4a26e8757949ccf71a0be9223a1e6eb4084142efb84bddccc9fb60ce0fbbfb209638338ad7ac0868d937df612828ecc856ecfa1aeb0c8ce8f1ad582d472e6eef WHIRLPOOL 0aac733eac086b3bdf2a306df06de75ddd8cff24fbc9801d50f30137cd0fe95f07b217e70d4a784b0499e8077576ed226e673ccfcbfd33d91f528d2f5c9f9737
DIST cups-filters-1.16.0.tar.xz 1433588 SHA256 b37c6a4e8806035ce229c055ec66a4258f3b3c5346f1f0ad535db1b5ee6f96cd SHA512 f62f8c42f130f715df4a1f98a4366781791a88096213f5f54d34d7142ffc07d046b4b16b5f579b9f6ac96880b2cce24531aed3e3a47372747353da980e9f21ea WHIRLPOOL 38355450dfdd6a54cbe229a9859a40ad28473fc618be156f5a429aa17805e0978de8ddb41be88d0b6d0303eefe0058e6f6952c43a997c83f27cfdad77b1308fe
DIST cups-filters-1.16.1.tar.xz 1435472 SHA256 32da05c059a8f7f74eb78abdfffe1dddad9dd8439771e2232be7aef71a4443a3 SHA512 3d3f81047a8fee965998158f5b2be570104c74f11ea4e8a489ee30d1d97246d0829a1ebc4a9b060718c6cc0eaeb94dc518a08a2c14a8cdcdfa70228c09875a15 WHIRLPOOL 51697dc39ac395e160183dcfffe8f564083f360b26861a23527cc6364b69d8c78d90ccbfaec34fbe9fde1e4267985794e00f8e3b75228cd3d67c01b7bd052fe0
DIST cups-filters-1.5.0.tar.xz 1375588 SHA256 f22a8864e8d5b693795605a31345c08cc68f85120ebde9a0aa7bc27639815932 SHA512 81574f8368aaef61aeee4369caa394f2c8cdc717b03687d8a17c7927892f07cff68f1efb8d674757cb97001b55fd58fa5c14784a510ce9d31e385b1a73cd18c7 WHIRLPOOL 4201d08a2bb76d349a6b9f7220eb48dea86bb81c0cedbe8dcb8796c49ce26f67f6a7c49677b4fc7b6f865eb20e3c806746f565668e9f9e1e3935630621d032cd
134 changes: 134 additions & 0 deletions net-print/cups-filters/cups-filters-1.16.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,134 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

GENTOO_DEPEND_ON_PERL=no

inherit perl-module systemd flag-o-matic

if [[ "${PV}" == "9999" ]] ; then
inherit bzr autotools
EBZR_REPO_URI="http://bzr.linuxfoundation.org/openprinting/cups-filters"
else
SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~m68k-mint"
fi
DESCRIPTION="Cups PDF filters"
HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/pdf_as_standard_print_job_format"

LICENSE="MIT GPL-2"
SLOT="0"
IUSE="dbus +foomatic ipp_autosetup jpeg ldap pdf perl png +postscript static-libs tiff zeroconf"

RDEPEND="
>=app-text/poppler-0.32:=[cxx,jpeg?,lcms,tiff?,utils]
>=app-text/qpdf-3.0.2:=
dev-libs/glib:2
media-libs/fontconfig
media-libs/freetype:2
media-libs/lcms:2
>=net-print/cups-1.7.3
!<=net-print/cups-1.5.9999
sys-devel/bc
sys-libs/zlib
dbus? ( sys-apps/dbus )
foomatic? ( !net-print/foomatic-filters )
jpeg? ( virtual/jpeg:0 )
ldap? ( net-nds/openldap )
pdf? ( app-text/mupdf )
perl? ( dev-lang/perl:= )
png? ( media-libs/libpng:0= )
postscript? ( >=app-text/ghostscript-gpl-9.09[cups] )
tiff? ( media-libs/tiff:0 )
zeroconf? ( net-dns/avahi[dbus] )
"
DEPEND="${RDEPEND}
dev-util/gdbus-codegen
"

src_prepare() {
default
[[ "${PV}" == "9999" ]] && eautoreconf

# Bug #626800
append-cxxflags -std=c++11
}

src_configure() {
local myeconfargs=(
--docdir="${EPREFIX}/usr/share/doc/${PF}"
--enable-imagefilters
--localstatedir="${EPREFIX}"/var
--with-browseremoteprotocols=DNSSD,CUPS
--with-cups-rundir="${EPREFIX}"/run/cups
--with-fontdir="fonts/conf.avail"
--with-pdftops=pdftops
--with-rcdir=no
--without-php
$(use_enable dbus)
$(use_enable foomatic)
$(use_enable ipp_autosetup auto-setup-driverless)
$(use_enable ldap)
$(use_enable pdf mutool)
$(use_enable postscript ghostscript)
$(use_enable postscript ijs)
$(use_enable static-libs static)
$(use_enable zeroconf avahi)
$(use_with jpeg)
$(use_with png)
$(use_with tiff)
)
econf "${myeconfargs[@]}"
}

src_compile() {
default

if use perl; then
pushd "${S}/scripting/perl" > /dev/null
perl-module_src_configure
perl-module_src_compile
popd > /dev/null
fi
}

src_install() {
default

if use perl; then
pushd "${S}/scripting/perl" > /dev/null
perl-module_src_install
perl_delete_localpod
popd > /dev/null
fi

if use postscript; then
# workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
dosym gstoraster /usr/libexec/cups/filter/pstoraster
dosym gstopxl /usr/libexec/cups/filter/pstopxl
fi

find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die

cp "${FILESDIR}"/cups-browsed.init.d-r1 "${T}"/cups-browsed || die

if ! use zeroconf ; then
sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
fi

doinitd "${T}"/cups-browsed
systemd_dounit "${S}/utils/cups-browsed.service"
}

src_test() {
emake check
}

pkg_postinst() {
if ! use foomatic ; then
ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
ewarn "necessary. net-print/foomatic-filters as replacement is deprecated and unmaintained."
fi
}

0 comments on commit 21f0b64

Please sign in to comment.