Skip to content

Commit

Permalink
media-plugins/kipi-plugins: Version bump 5.0.0
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
johu committed Jul 10, 2016
1 parent f6918d3 commit 22d2b59
Show file tree
Hide file tree
Showing 3 changed files with 98 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-plugins/kipi-plugins/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST digikam-4.14.0.tar.bz2 59805228 SHA256 9d7bcb689d8c29be2e81976f0a043220f442a24f2071284044e7f1a799a7fdad SHA512 3029e9b67d9d055bd9aee0d6d01e87950702e026f9f44b513155946ba087ec58b300f945a035a418afae45365ed007d8db6a1a90ed1d391e5e0e4cb679168ccf WHIRLPOOL 35a3caedc9a4799f161b26b3b4df51da18a31be50a8a6da5b12a339a353755d73a47f103099087e3dc8e6926f65ae19638efea3585c86f72173a086056bf48ce
DIST digikam-4.4.0.tar.bz2 68871203 SHA256 5c68a2d200f5b502706128ea64839319aad333fb79548f49ecc92594e280d4e9 SHA512 4992fad1e574fc44eac53f3ac8d4ab78ccbf8e04beb54a211a9afc20af1efb6f8bacedea07e403f490e7f70a74ed5ac02d4f9b939dfaf25f64a4a9bda0a7d94a WHIRLPOOL 7a05ab9926227232a1cf52bf68da45b849b982e840b171f702610acce85a1ce8e59967a02e845a0ef19c316daee835861573aca40dc7b28422cf7d6d56119e2c
DIST digikam-5.0.0.tar.xz 62980708 SHA256 b0b4fb7f55101830b8a49d804f622f80e82386d1597cb1b94e6d2f287ab33d9f SHA512 99cd961b2261a76a2743ecabfb64195b941dc20f8fc57318cef9ca6e34ca9bd5c944c6019aa92b493316db47385a98f0f77fa04fcbd20ac0e3b01a03936eddfb WHIRLPOOL c15d19da31c7ba0679475fca7dc9f9b60104fee9f55a7b41b4b655e37d910d0bc963ebfd87a241ef5536ef4a0c362be42e6c5b054ee5a46998bee54ef8ad41f3
96 changes: 96 additions & 0 deletions media-plugins/kipi-plugins/kipi-plugins-5.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,96 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

KDE_HANDBOOK="true"
KDE_TEST="true"
VIRTUALX_REQUIRED="test"
inherit kde5

DESCRIPTION="Plugins for the KDE Image Plugin Interface"
HOMEPAGE="http://www.digikam.org/"

LICENSE="GPL-2+ handbook? ( FDL-1.2 )"
KEYWORDS="~amd64 ~x86"
IUSE="flashexport mediawiki vkontakte"

if [[ ${KDE_BUILD_TYPE} = release ]]; then
MY_PV="${PV/_/-}"
MY_P="digikam-${MY_PV}"

if [[ ${PV} =~ beta[0-9]$ ]]; then
SRC_BRANCH="unstable"
else
SRC_BRANCH="stable"
fi

SRC_URI="mirror://kde/${SRC_BRANCH}/digikam/${MY_P}.tar.xz"

S="${WORKDIR}/${MY_P}/extra/${PN}"
fi

COMMON_DEPEND="
$(add_frameworks_dep kcompletion)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kconfigwidgets)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kio)
$(add_frameworks_dep kservice)
$(add_frameworks_dep kwindowsystem)
$(add_frameworks_dep kxmlgui)
$(add_qt_dep qtconcurrent)
$(add_qt_dep qtgui)
$(add_qt_dep qtnetwork)
$(add_qt_dep qtprintsupport)
$(add_qt_dep qtsvg)
$(add_qt_dep qtwidgets)
$(add_qt_dep qtxml)
$(add_qt_dep qtxmlpatterns)
kde-apps/libkipi:5=
flashexport? ( $(add_frameworks_dep karchive) )
mediawiki? ( net-libs/libmediawiki:5 )
vkontakte? ( net-libs/libkvkontakte:5 )
"
DEPEND="${COMMON_DEPEND}
sys-devel/gettext
"
RDEPEND="${COMMON_DEPEND}
!media-plugins/kipi-plugins:4
"

# hangs
RESTRICT="test"

src_prepare() {
if [[ ${KDE_BUILD_TYPE} = release ]]; then
# prepare the handbook
mv "${WORKDIR}"/${MY_P}/doc/${PN} "${S}"/doc || die

if use handbook; then
echo "add_subdirectory( doc )" >> CMakeLists.txt || die
fi

if [[ ${SRC_BRANCH} = stable ]]; then
# prepare the translations
mv "${WORKDIR}/${MY_P}/po" po || die
find po -name "*.po" -and -not -name "kipiplugin*.po" -delete || die
echo "find_package(Gettext REQUIRED)" >> CMakeLists.txt || die
echo "add_subdirectory( po )" >> CMakeLists.txt || die
fi
fi

kde5_src_prepare
}

src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package flashexport KF5Archive)
$(cmake-utils_use_find_package mediawiki KF5MediaWiki)
$(cmake-utils_use_find_package vkontakte KF5Vkontakte)
)

kde5_src_configure
}
1 change: 1 addition & 0 deletions media-plugins/kipi-plugins/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -10,6 +10,7 @@
</maintainer>
<use>
<flag name="expoblending">Build the expoblending plugin, which requires media-gfx/hugin</flag>
<flag name="flashexport">Build the flash export plugin</flag>
<flag name="gpssync">Build the gpssync plugin, which requires kde-apps/libkgeomap and thereby marble</flag>
<flag name="mediawiki">Build the mediawiki export plugin</flag>
<flag name="panorama">Pull in dependencies needed by panorama plugin</flag>
Expand Down

0 comments on commit 22d2b59

Please sign in to comment.