Skip to content

Commit

Permalink
app-misc/fdupes: Drop obsolete patch; add live version
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Aug 11, 2015
1 parent 9a1061d commit 233842f
Show file tree
Hide file tree
Showing 4 changed files with 63 additions and 44 deletions.
35 changes: 35 additions & 0 deletions app-misc/fdupes/fdupes-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils flag-o-matic git-r3 toolchain-funcs

MY_P="${PN}-${PV/_pre/-PR}"

DESCRIPTION="Identify/delete duplicate files residing within specified directories"
HOMEPAGE="https://github.com/adrianlopezroche/fdupes https://code.google.com/p/fdupes/"
SRC_URI=""
EGIT_REPO_URI="https://github.com/adrianlopezroche/fdupes.git"

LICENSE="MIT"
SLOT="0"
KEYWORDS=""
IUSE=""

S="${WORKDIR}/${MY_P}"

src_prepare() {
epatch \
"${FILESDIR}"/${P}-makefile.patch

append-lfs-flags
tc-export CC
}

src_install() {
dobin fdupes
doman fdupes.1
dodoc CHANGES CONTRIBUTORS README TODO
}
21 changes: 0 additions & 21 deletions app-misc/fdupes/files/fdupes-1.50_pre2-lfs.patch

This file was deleted.

23 changes: 0 additions & 23 deletions app-misc/fdupes/files/fdupes-1.50_pre2-makefile.patch

This file was deleted.

28 changes: 28 additions & 0 deletions app-misc/fdupes/files/fdupes-9999-makefile.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
Makefile | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/Makefile b/Makefile
index 921d910..67576f9 100644
--- a/Makefile
+++ b/Makefile
@@ -78,9 +78,9 @@ MKDIR = mkdir -p
# Make Configuration
#
CC ?= gcc
-COMPILER_OPTIONS = -Wall -O -g
+CFLAGS ?= -Wall -O -g

-CFLAGS= $(COMPILER_OPTIONS) -I. -DVERSION=\"$(VERSION)\" $(EXTERNAL_MD5) $(OMIT_GETOPT_LONG) $(FILEOFFSET_64BIT)
+CFLAGS += -I. -DVERSION=\"$(VERSION)\" $(EXTERNAL_MD5) $(OMIT_GETOPT_LONG) $(FILEOFFSET_64BIT)

INSTALL_PROGRAM = $(INSTALL) -c -m 0755
INSTALL_DATA = $(INSTALL) -c -m 0644
@@ -100,7 +100,7 @@ OBJECT_FILES = fdupes.o md5/md5.o $(ADDITIONAL_OBJECTS)
all: fdupes

fdupes: $(OBJECT_FILES)
- $(CC) $(CFLAGS) -o fdupes $(OBJECT_FILES)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o fdupes $(OBJECT_FILES)

installdirs:
test -d $(DESTDIR)$(BIN_DIR) || $(MKDIR) $(DESTDIR)$(BIN_DIR)

0 comments on commit 233842f

Please sign in to comment.