forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-extra/gnome-shell-extension-gsconnect: Bump to v33
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Pacho Ramos <[email protected]>
- Loading branch information
Showing
2 changed files
with
65 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST gnome-shell-extension-gsconnect-28.tar.gz 312814 BLAKE2B 217e32e799c6300764f23245c0d474b025918f78808c026175fd3262b4c463b913969290156782151828cdcb15647002e7c7b8bff926337960a78d6d98a16c77 SHA512 a806f6532e68544832dac47da1fdf23edb7625c6cac4ad7f1c1a1b0a5d69af159397bc6f2bb63a74907669db5ea192343b7d2fc8eb2992bcc6a1834cffe1fbba | ||
DIST gnome-shell-extension-gsconnect-33.tar.gz 314704 BLAKE2B fa4f2eb6325356a058b24b92b683ca7331af30112d27060e8ee191c21a3269639da58992d53434c7121ea511ee9e07869b082f908b59e19fc2434f3c07e09624 SHA512 26ef929b9b128db0cb29fba22203a3afd500c5b1c3bac6917926a60350d271e67bb0985866f84877355c079fe4a5656b8ac5e8dae976d17d9a068cc825293bce |
64 changes: 64 additions & 0 deletions
64
gnome-extra/gnome-shell-extension-gsconnect/gnome-shell-extension-gsconnect-33.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,64 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
inherit gnome2-utils meson readme.gentoo-r1 | ||
|
||
DESCRIPTION="KDE Connect implementation for Gnome Shell" | ||
HOMEPAGE="https://github.com/andyholmes/gnome-shell-extension-gsconnect" | ||
SRC_URI="https://github.com/andyholmes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="nautilus" | ||
|
||
COMMON_DEPEND="dev-libs/glib:2" | ||
RDEPEND="${COMMON_DEPEND} | ||
app-eselect/eselect-gnome-shell-extensions | ||
>=dev-libs/gjs-1.48 | ||
=gnome-base/gnome-shell-3.34* | ||
gnome-base/gvfs | ||
gnome-extra/evolution-data-server | ||
|| ( media-libs/libcanberra media-libs/gsound ) | ||
nautilus? ( | ||
dev-python/nautilus-python | ||
gnome-base/nautilus[introspection] ) | ||
" | ||
DEPEND="${COMMON_DEPEND}" | ||
BDEPEND=" | ||
virtual/pkgconfig | ||
" | ||
|
||
DISABLE_AUTOFORMATTING="yes" | ||
DOC_CONTENTS="For knowing more about how to do the setup, please visit: | ||
https://github.com/andyholmes/gnome-shell-extension-gsconnect/wiki/Installation" | ||
|
||
src_configure() { | ||
# nemo support relies on nemo-python from https://github.com/linuxmint/nemo-extensions | ||
# https://bugs.gentoo.org/694388 | ||
meson_src_configure \ | ||
-Dnemo=false \ | ||
$(meson_use nautilus) | ||
} | ||
|
||
src_install() { | ||
meson_src_install | ||
readme.gentoo_create_doc | ||
} | ||
|
||
pkg_preinst() { | ||
gnome2_schemas_savelist | ||
} | ||
|
||
pkg_postinst() { | ||
gnome2_schemas_update | ||
ebegin "Updating list of installed extensions" | ||
eselect gnome-shell-extensions update | ||
eend $? | ||
readme.gentoo_print_elog | ||
} | ||
|
||
pkg_postrm() { | ||
gnome2_schemas_update | ||
} |