Skip to content

Commit

Permalink
media-libs/libraw: fix build failure against glibc-2.27, bug #647556
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/647556
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
Sergei Trofimovich committed Feb 18, 2018
1 parent 754dfca commit 23a185e
Show file tree
Hide file tree
Showing 4 changed files with 28 additions and 2 deletions.
14 changes: 14 additions & 0 deletions media-libs/libraw/files/libraw-0.18.4-glibc-2.27.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
Fix build failure on glibc-2.27 caused by pow64 symbol collision.

https://github.com/LibRaw/LibRaw/pull/115
https://bugs.gentoo.org/647556
diff --git a/internal/dcraw_common.cpp b/internal/dcraw_common.cpp
index 18bcdbc..8cec744 100644
--- a/internal/dcraw_common.cpp
+++ b/internal/dcraw_common.cpp
@@ -5770,4 +5770,5 @@ static float powf_lim(float a, float b, float limup)
return (b>limup || b < -limup)?0.f:powf(a,b);
}
+#define powf64 powf_lim64 /* workaround symbol collision */
static float powf64(float a, float b)
{
6 changes: 5 additions & 1 deletion media-libs/libraw/libraw-0.18.4.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand Down Expand Up @@ -32,6 +32,10 @@ S=${WORKDIR}/${MY_P}

DOCS=( Changelog.txt README )

PATCHES=(
"${FILESDIR}"/${PN}-0.18.4-glibc-2.27.patch
)

pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
Expand Down
6 changes: 5 additions & 1 deletion media-libs/libraw/libraw-0.18.6.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand Down Expand Up @@ -32,6 +32,10 @@ S="${WORKDIR}/${MY_P}"

DOCS=( Changelog.txt README )

PATCHES=(
"${FILESDIR}"/${PN}-0.18.4-glibc-2.27.patch
)

pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
Expand Down
4 changes: 4 additions & 0 deletions media-libs/libraw/libraw-0.18.7.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -32,6 +32,10 @@ S="${WORKDIR}/${MY_P}"

DOCS=( Changelog.txt README )

PATCHES=(
"${FILESDIR}"/${PN}-0.18.4-glibc-2.27.patch
)

pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
Expand Down

0 comments on commit 23a185e

Please sign in to comment.