Skip to content

Commit

Permalink
dev-util/kdevelop: Version bump 5.3.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Signed-off-by: Maciej Mrozowski <[email protected]>
  • Loading branch information
reavertm committed Nov 19, 2018
1 parent 823bd2d commit 23b5e9d
Show file tree
Hide file tree
Showing 2 changed files with 134 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/kdevelop/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST kdevelop-5.2.4.tar.xz 6647172 BLAKE2B c3dc301cf16bdef95000aa6cb3ebe615054f49ad29bc67870c31d329cf7bd4df81dad330eb26dd28c19627b2040f62522d755afa4450bb125872350d1f8039e1 SHA512 1c64b4f56452e8c926c5bcea5a9d8368fa62926d1ec507d289d8cb47275d478898d56fdf083fc24e291aaf4738cc5b7ddfd239e6993848e862bc4d83e270558b
DIST kdevelop-5.3.0.tar.xz 6698296 BLAKE2B 51547eda3b0c0505fc92acd9cb02b2eea3d97aa148bb5c659115688dee9ead4e025fc4d34d4da7e6bc55b2aa38d854f63ffa05604129c34f5f6151de9665b716 SHA512 dbe628378094515911b8e1cac9ed8fedabaf495e68d87b199b5beb5121b936e7ea245c567e91db5a9ecb477f3b636fa62da41d4c70395273e234430ec72e62fd
133 changes: 133 additions & 0 deletions dev-util/kdevelop/kdevelop-5.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,133 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

EGIT_BRANCH="5.3"
KDE_HANDBOOK="forceoptional"
KDE_TEST="true"
VIRTUALDBUS_TEST="true"
VIRTUALX_REQUIRED="test"
inherit kde5

DESCRIPTION="Integrated Development Environment, supporting KF5/Qt, C/C++ and much more"
LICENSE="GPL-2 LGPL-2"
IUSE="cvs +gdbui hex +plasma +qmake reviewboard subversion webkit"
[[ ${KDE_BUILD_TYPE} = release ]] && KEYWORDS="~amd64 ~x86"

COMMON_DEPEND="
$(add_frameworks_dep karchive)
$(add_frameworks_dep kbookmarks)
$(add_frameworks_dep kcmutils)
$(add_frameworks_dep kcodecs)
$(add_frameworks_dep kcompletion)
$(add_frameworks_dep kconfig)
$(add_frameworks_dep kconfigwidgets)
$(add_frameworks_dep kcoreaddons)
$(add_frameworks_dep kcrash)
$(add_frameworks_dep kdeclarative)
$(add_frameworks_dep kguiaddons)
$(add_frameworks_dep ki18n)
$(add_frameworks_dep kiconthemes)
$(add_frameworks_dep kio)
$(add_frameworks_dep kitemmodels)
$(add_frameworks_dep kitemviews)
$(add_frameworks_dep kjobwidgets)
$(add_frameworks_dep knewstuff)
$(add_frameworks_dep knotifications)
$(add_frameworks_dep knotifyconfig)
$(add_frameworks_dep kparts)
$(add_frameworks_dep kservice)
$(add_frameworks_dep ktexteditor)
$(add_frameworks_dep ktextwidgets)
$(add_frameworks_dep kwidgetsaddons)
$(add_frameworks_dep kwindowsystem)
$(add_frameworks_dep kxmlgui)
$(add_frameworks_dep sonnet)
$(add_frameworks_dep threadweaver)
$(add_kdeapps_dep libkomparediff2)
$(add_qt_dep qtdbus)
$(add_qt_dep qtdeclarative 'widgets')
$(add_qt_dep qtgui)
$(add_qt_dep qthelp)
$(add_qt_dep qtnetwork)
$(add_qt_dep qttest)
$(add_qt_dep qtwidgets)
$(add_qt_dep qtxml)
dev-libs/grantlee:5
>=sys-devel/clang-3.8.0:=
x11-misc/shared-mime-info
gdbui? ( $(add_plasma_dep libksysguard) )
hex? ( app-editors/okteta:5 )
plasma? (
$(add_frameworks_dep krunner)
$(add_frameworks_dep plasma)
)
qmake? ( dev-util/kdevelop-pg-qt:5 )
reviewboard? ( $(add_frameworks_dep purpose) )
subversion? (
dev-libs/apr:1
dev-libs/apr-util:1
dev-vcs/subversion
)
webkit? ( $(add_qt_dep qtwebkit) )
!webkit? ( $(add_qt_dep qtwebengine 'widgets') )
"
DEPEND="${COMMON_DEPEND}
dev-libs/boost
$(add_qt_dep qtconcurrent)
"
RDEPEND="${COMMON_DEPEND}
$(add_kdeapps_dep kapptemplate)
$(add_kdeapps_dep kio-extras)
dev-util/ninja
>=sys-devel/gdb-7.0[python]
cvs? ( dev-vcs/cvs )
reviewboard? ( $(add_kdeapps_dep ktp-accounts-kcm) )
!dev-util/kdevelop-clang
!dev-util/kdevelop-cppcheck
!dev-util/kdevelop-qmake
!dev-util/kdevelop-qmljs
!dev-util/kdevplatform
"

RESTRICT+=" test"
# see bug 366471

src_configure() {
local mycmakeargs=(
-DBUILD_cvs=$(usex cvs)
$(cmake-utils_use_find_package gdbui KF5SysGuard)
-DBUILD_executeplasmoid=$(usex plasma)
$(cmake-utils_use_find_package plasma KF5Plasma)
$(cmake-utils_use_find_package hex OktetaKastenControllers)
$(cmake-utils_use_find_package qmake KDevelop-PG-Qt)
$(cmake-utils_use_find_package reviewboard KF5Purpose)
$(cmake-utils_use_find_package subversion SubversionLibrary)
$(cmake-utils_use_find_package !webkit Qt5WebEngineWidgets)
)

use reviewboard || mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_KDEExperimentalPurpose=ON )

kde5_src_configure
}

pkg_postinst() {
kde5_pkg_postinst

if ! has_version "kde-apps/konsole" ; then
elog "For konsole view, please install kde-apps/konsole"
fi

if ! has_version "dev-util/cppcheck" ; then
elog "For static C/C++ code analysis support, please install dev-util/cppcheck"
fi

if ! has_version "dev-util/heaptrack[qt5]" ; then
elog "For heap memory profiling support, please install dev-util/heaptrack"
fi

if ! has_version "dev-util/clazy" ; then
elog "For static C++ Qt code analysis support, please install dev-util/clazy"
fi
}

0 comments on commit 23b5e9d

Please sign in to comment.