Skip to content

Commit

Permalink
dev-ruby/nio4r: add 2.5.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Sep 25, 2019
1 parent ed29eb6 commit 240f617
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/nio4r/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST nio4r-1.2.1.gem 94208 BLAKE2B 229c1c690004444a6701ad765af26e592b9dbdb3646f1
DIST nio4r-2.3.1.gem 101888 BLAKE2B 1891581eaa8659ed86f13e365664974ea55921e0107b7ce9757961cebe27f290995e90c17d375b35cf15245856c7c1d61fd05a332dc09032fffc1599bc2474ab SHA512 6e8fbc744f17b42a0a5c9f8f6db79ce3c9c0dbf6cb047f0b48faab813effc9f5dabe7405475a755bea9f0eb49037f6f26bdc6b8ff3fc7ab3bca61fc238e4eb6d
DIST nio4r-2.4.0.gem 101888 BLAKE2B 05f0223ccf493d3566d370e3199b26136b4158939fcd7102d5d513ae0988c3691fedb00fe47f9884396bc333ed2b88b605c583048ad6a2ebe70eb7aa4b70a6df SHA512 2cd77c4af934c10cbcc23e926d0111a319bd9be69b0ead9c5c5614911f2cd3127ffa9fb103907d961b59e6f846cc83ac9a97722a85dac390dbf2f2a20976a0c0
DIST nio4r-2.5.1.gem 110080 BLAKE2B 4d439cf67dc45deab9107d7c4ef9853f12f3ab88537bea9d83050d57c439cb850a9b883d1c2fa83da6c197b5257a7938fd55c4d3e65af3115cb2bd810e8b3176 SHA512 a99d44b0deaa298e2ad2b3dce5ec8889f7a95cb8b44f453fd2cb84c94354316c158fbce4bb7b3e302b22cb272c3354516584cc1432ca08968144d3212ff69f9f
DIST nio4r-2.5.2.gem 110592 BLAKE2B b632322d0706f97a30601e7135daad9ee5a66e57ff7dea1eb0b8365e45f896e7b8a7c228c4eb781d2f44ea047eb028549bc172b68a0540d041ad83bd79d25075 SHA512 3db567c9994e9186749e37c3ebc07f744e7a82c1163d44222475cf491f945745c6c070f4a0a8c77e331921147cc1f5f7bfffd86cb3455d5864280c4e4945b295
40 changes: 40 additions & 0 deletions dev-ruby/nio4r/nio4r-2.5.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

USE_RUBY="ruby24 ruby25 ruby26"

RUBY_FAKEGEM_RECIPE_TEST="rspec3"

RUBY_FAKEGEM_RECIPE_DOC=""
RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"

inherit ruby-fakegem

DESCRIPTION="A high performance selector API for monitoring IO objects"
HOMEPAGE="https://github.com/socketry/nio4r"

LICENSE="MIT || ( BSD GPL-2 )"
SLOT="2"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""

# Note that nio4r bundles a patched copy of libev, and without these
# patches the tests fail: https://github.com/celluloid/nio4r/issues/15

ruby_add_bdepend "test? ( dev-ruby/rspec-retry )"

all_ruby_prepare() {
sed -i -e '/[Cc]overalls/d' -e '/[Bb]undler/d' spec/spec_helper.rb || die
sed -e '/extension/ s:^:#:' -i Rakefile || die
}

each_ruby_configure() {
${RUBY} -Cext/${PN} extconf.rb || die
}

each_ruby_compile() {
emake V=1 -Cext/${PN}
cp ext/${PN}/*$(get_modname) lib/ || die
}

0 comments on commit 240f617

Please sign in to comment.