forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Bug: https://bugs.gentoo.org/684920 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: David Denoncin <[email protected]> Closes: gentoo#22807 Signed-off-by: Sam James <[email protected]>
- Loading branch information
1 parent
ad6f86b
commit 24bff02
Showing
2 changed files
with
69 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,4 @@ | ||
DIST task-2.5.3.tar.gz 788760 BLAKE2B 3e8a4f2ebf6c39d3d51dc9b044cf1c8fbce23ab8178b6645405f26522bbb6f29e9f78247fe52601f6c8f87f966a3b7aad130417d0f416b9d969e9e396c10eafc SHA512 e906c8f42ad4b9a7e20a82defe31b89194d72957f18dd5129ecc41a2a60a9d8b0d01abb9b44ecce79b65cd9064af4a4a4c9dd695f98152e77908f130dc3f9677 | ||
DIST task-2.6.1.tar.gz 836830 BLAKE2B 18531a462e9466d2bfc21af70c05ec75f504c82e67ff4160378dd1dc2438955284eb430ec92969ffd212e9e92b14d6bea6013beda8eb353bfb7b8aac03bbbb2d SHA512 996690831967b5b248d336f0848aa243d5929a34238d05a78d49930f477a7927966d097119cf2dd935aa1c159e930f74bac07b05327504b15d235348927b657b | ||
DIST tests-2.5.3.tar.gz 223579 BLAKE2B 89a7fda3726d9923388675f34fe40a6a597901b2ab6c90a345b89d4ba00660e6a7533c4752fc4fe6f77344594a322c17eb43866028c26d005ce44cf12c11c355 SHA512 f6a58407f172385e9955b21b7fffeb510f852bd055ada4869547e396856c7df01b8414a51de6bc8530b29d8ca0fa7e74a8e35aa7bc88fe1e15bda7035a5fadd1 | ||
DIST tests-2.6.1.tar.gz 221364 BLAKE2B 6aac691ba1828abb3469dfa2a9c093b92431591ac21113f71550676f7f9c40394770ddd2c649bf6cda5655d5f1c25aa6c7ef174e9da7ea0c647109d25771dc2d SHA512 df252b252ac7e319d46ef7e72c587c52a97bf7b496ad401342611114db15b7fdab501b4fffc60ea6a8dca7820abc267120375a1aafd1da0a0c41b925e9fd62da |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,67 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
CMAKE_MAKEFILE_GENERATOR="emake" | ||
inherit bash-completion-r1 cmake | ||
|
||
DESCRIPTION="Taskwarrior is a command-line todo list manager" | ||
HOMEPAGE="https://taskwarrior.org/" | ||
SRC_URI="https://github.com/GothenburgBitFactory/taskwarrior/releases/download/v${PV}/${P}.tar.gz | ||
https://github.com/GothenburgBitFactory/taskwarrior/releases/download/v${PV}/tests-${PV}.tar.gz" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~x86 ~x64-macos" | ||
IUSE="+sync" | ||
|
||
DEPEND=" | ||
sync? ( net-libs/gnutls ) | ||
" | ||
RDEPEND="${DEPEND}" | ||
|
||
src_prepare() { | ||
# move test directory into source directory | ||
mv "${WORKDIR}"/test "${WORKDIR}"/${P} || die | ||
|
||
cmake_src_prepare | ||
|
||
# don't automatically install scripts | ||
sed -i '/scripts/d' CMakeLists.txt || die | ||
} | ||
|
||
src_configure() { | ||
mycmakeargs=( | ||
-DENABLE_SYNC=$(usex sync) | ||
-DTASK_DOCDIR=share/doc/${PF} | ||
-DTASK_RCDIR=share/${PN}/rc | ||
-DBUILD_SHARED_LIBS=off # bug 764224 | ||
) | ||
|
||
cmake_src_configure | ||
} | ||
|
||
src_test() { | ||
cd "${WORKDIR}"/"${P}"_build || die | ||
|
||
emake test | ||
} | ||
|
||
src_install() { | ||
cmake_src_install | ||
|
||
newbashcomp scripts/bash/task.sh task | ||
|
||
# vim syntax | ||
rm scripts/vim/README || die | ||
insinto /usr/share/vim/vimfiles | ||
doins -r scripts/vim/* | ||
|
||
# zsh-completions | ||
insinto /usr/share/zsh/site-functions | ||
doins scripts/zsh/* | ||
|
||
exeinto "/usr/share/${PN}/scripts" | ||
doexe scripts/add-ons/* | ||
} |