forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-tcltk/itcl: version bump to 4.2.0
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Alfredo Tupone <[email protected]>
- Loading branch information
Showing
2 changed files
with
63 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST itcl3.4.1.tar.gz 263316 BLAKE2B ba4a94d2dfe80b095e754d01036b189130918d7f29701f003873d59fa8e75074b1601dd907d94e5a9f680e05b18493d5782d6a4ddbb56d7df9ff85c8d5b17ecf SHA512 288c9b636f1814371bedd33d570a8d46055e136953685a111b76f3b89a6c7aaa1ee9223ceaae1c5ce43198195cb1adc2b178d7c4101d7fd14cb7e756c98bf2b0 | ||
DIST itcl4.0.3.tar.gz 430522 BLAKE2B e1ce0325a501b0227f6ec721927488dff0e2ea323bb8b03b046ce23964b55cdf44d7633f34546b9b0432785e609bb7dddeb3a300cbb2d82a9e4eb70acb1bfd66 SHA512 9736a08f0f33e0afa677a77eb643454908531786435b73314a80d9ee211c06f037eb0de3c2c2608b728253f9ec613a601d76f16f29964eb06b667ecbb3400df4 | ||
DIST itcl4.1.1.tar.gz 436718 BLAKE2B 50f5518460dc6569edcd0229b71439cb10a724b50c31387ebd1ffa85f9fbf58d5bd5163847a1d7ffa791d5acd5d72b08188f01f0e5c4730ba9060fc531071cd4 SHA512 1e08dbefe33e5464320c62e32d153b3e473462cded2d715ba1c504deacf190062672fbece40a021f25798440e2fbed4ecda763db5789fc6afb5eb2052bdf66e2 | ||
DIST itcl4.2.0.tar.gz 428635 BLAKE2B 38898f3377583115eed3b4d5a8a610e0d0a515a1e4852fe3cea04eea68fe64f158bc79d7d5f3041831f97e5e28cee5a67721a187ed5cfbaa33c69e4668b55f31 SHA512 42d13d7f4f841bff49c508fe5d17c12e81b7e381db470d7db658c925b6e609a0821953aa8344764633a3b996eb5757aaae7014df13f4e38ade2dd7aa068ba385 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,62 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit eutils multilib | ||
|
||
MY_P="${PN}${PV}" | ||
|
||
DESCRIPTION="Object Oriented Enhancements for Tcl/Tk" | ||
HOMEPAGE="http://incrtcl.sourceforge.net/" | ||
SRC_URI="mirror://sourceforge/project/incrtcl/%5Bincr%20Tcl_Tk%5D-4-source/itcl%20${PV}/${MY_P}.tar.gz" | ||
|
||
SLOT="0" | ||
LICENSE="BSD" | ||
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos" | ||
IUSE="" | ||
|
||
RDEPEND=">=dev-lang/tcl-8.6:0=" | ||
DEPEND="${RDEPEND}" | ||
|
||
S="${WORKDIR}/${PN}${PV}" | ||
|
||
# somehow broken | ||
#RESTRICT=test | ||
|
||
src_configure() { | ||
econf \ | ||
--with-tcl="${EPREFIX}"/usr/$(get_libdir) \ | ||
--with-tclinclude="${EPREFIX}"/usr/include \ | ||
--disable-rpath | ||
} | ||
|
||
src_compile() { | ||
# adjust install_name on darwin | ||
if [[ ${CHOST} == *-darwin* ]]; then | ||
sed -i \ | ||
-e 's:^\(SHLIB_LD\W.*\)$:\1 -install_name ${pkglibdir}/$@:' \ | ||
"${S}"/Makefile || die 'sed failed' | ||
fi | ||
|
||
sed 's:-pipe::g' -i Makefile || die | ||
|
||
emake CFLAGS_DEFAULT="${CFLAGS}" | ||
} | ||
|
||
src_install() { | ||
default | ||
|
||
sed \ | ||
-e "/BUILD_LIB_SPEC/s:-L${S}::g" \ | ||
-e "/BUILD_STUB_LIB_SPEC/s:-L${S}::g" \ | ||
-e "/BUILD_STUB_LIB_PATH/s:${S}:${EPREFIX}/usr/$(get_libdir)/${MY_P}/:g" \ | ||
-e "/INCLUDE_SPEC/s:${S}/generic:${EPREFIX}/usr/include:g" \ | ||
-e "s:${S}:${EPREFIX}/usr/$(get_libdir)/${MY_P}/:g" \ | ||
-i "${ED}"/usr/$(get_libdir)/${MY_P}/itclConfig.sh || die | ||
|
||
cat >> "${T}"/34${PN} <<- EOF | ||
LDPATH="${EPREFIX}/usr/$(get_libdir)/${MY_P}/" | ||
EOF | ||
doenvd "${T}"/34${PN} | ||
} |