Skip to content

Commit

Permalink
app-crypt/tpm2-pkcs11: Bump to 1.3.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Signed-off-by: Salah Coronya <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
salahcoronya authored and juippis committed Aug 8, 2020
1 parent 54b5997 commit 25b7f1d
Show file tree
Hide file tree
Showing 2 changed files with 54 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-crypt/tpm2-pkcs11/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST tpm2-pkcs11-1.3.0.tar.gz 1257620 BLAKE2B 503a84a42f1698d1ae85d70473365bf2a58d4f6b8b4ae12629bbb9178de7f33655780b43d4e32f8489006b8e52dcb5cb8ba2a16844319ea5423ce11e9bb84f1d SHA512 27d48dd78534008ef7254f03673101a27740561bc0ad15dd3972d829d2e4677ed2e30d6cc95c6564ad225eb8652c9876cd9cbfab48a749b6d1576fae1b7a6ce2
DIST tpm2-pkcs11-1.3.1.tar.gz 1256873 BLAKE2B 16bf9c2806fe515cfc31e5885c940774d8d1a04d8a780c8a119db4d9c684e6db3ad3f719fa09d9dc7b6b0fb09212aa4745c53bd7253fd444ebfcb6b8f1dbeb3a SHA512 031b7411c135b2cb3b8f7c38af69a46e65088c4dc1da13ae5c44f92d2a2e293dfe2bea0adc68eb3e64b02b5445f55c353c5c209ecbc977411747fbd429ebdc86
53 changes: 53 additions & 0 deletions app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{7,8} )
DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_REQ_USE="sqlite"

inherit distutils-r1

DESCRIPTION="A PKCS#11 interface for TPM2 hardware"
HOMEPAGE="https://tpm2-software.github.io/"
SRC_URI="https://github.com/tpm2-software/tpm2-pkcs11/releases/download/${PV}/${P}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64"

# Test requires the IBM TPM simulator that's not in portage
RESTRICT="test"

RDEPEND="app-crypt/p11-kit
app-crypt/tpm2-abrmd
app-crypt/tpm2-tss
dev-db/sqlite:3
dev-libs/openssl
dev-python/cryptography[${PYTHON_USEDEP}]
dev-python/pyasn1[${PYTHON_USEDEP}]
dev-python/pyasn1-modules[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]"

DEPEND="${RDEPEND}"
BDEPEND="sys-devel/autoconf-archive
virtual/pkgconfig"

src_configure() {
default
}

src_compile() {
default
cd "${S}/tools" || die
BUILD_DIR="${S}/tools" python_foreach_impl distutils-r1_python_compile
}

src_install() {
default
cd "${S}/tools" || die
BUILD_DIR="${S}/tools" python_foreach_impl distutils-r1_python_install
dobin "${S}/tools/tpm2_ptool"
find "${D}" -name '*.la' -delete || die
}

0 comments on commit 25b7f1d

Please sign in to comment.