forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-emacs/ebuild-mode: Version bump to 1.51.
Closes: https://bugs.gentoo.org/698750 Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Ulrich Müller <[email protected]>
- Loading branch information
Showing
3 changed files
with
44 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST ebuild-mode-1.50.tar.xz 35440 BLAKE2B 281719a0a686ef1c80c8391cc118d14085ac6407dee5ee7ee44229bb529de041d31fcec7c08bb1e4b8b5057823c5d99a49a9786daa0b7b17a766155b7daaaecc SHA512 a7c232103848c7782a4ebad89e064f3bc37a78427228be799d8e1bd3670524b32050229ba7cd48d9e4c2b0bb32828ce95eb2e47038411591d03fa8f998614c1e | ||
DIST ebuild-mode-1.51.tar.xz 35280 BLAKE2B 63f57919bb73937ce3d40b4d6762e78c78d273bcf67875434d12450e00632d457d3dedbe6f213c1979a60cbc0a0874723e3e9424fdcfb64a48acc885cc90e577 SHA512 ff9ece96fbe7bfc9c070769dc6667e8c33f8fb7ef20a2d347c670342ef7500b52b54a93ed37ac9ea13a89c1b89752f5dd6e56c234abe9a4fcd4eb6bad0d0b466 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,22 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit elisp readme.gentoo-r1 | ||
|
||
DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files" | ||
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs" | ||
SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos" | ||
|
||
BDEPEND="sys-apps/texinfo" | ||
|
||
DOCS="ChangeLog keyword-generation.sh" | ||
ELISP_TEXINFO="${PN}.texi" | ||
SITEFILE="50${PN}-gentoo-1.51.el" | ||
DOC_CONTENTS="Some optional features may require installation of additional | ||
packages, like dev-python/docutils-glep for glep." |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,21 @@ | ||
(add-to-list 'load-path "@SITELISP@") | ||
(autoload 'ebuild-mode "ebuild-mode" | ||
"Major mode for Portage .ebuild and .eclass files." t) | ||
(autoload 'gentoo-newsitem-mode "gentoo-newsitem-mode" | ||
"Major mode for Gentoo GLEP 42 news items." t) | ||
(autoload 'glep-mode "glep-mode" | ||
"Major mode for Gentoo Linux Enhancement Proposals." t) | ||
|
||
(add-to-list 'auto-mode-alist '("\\.\\(ebuild\\|eclass\\)\\'" . ebuild-mode)) | ||
(add-to-list 'auto-mode-alist | ||
'("/[0-9]\\{4\\}-[01][0-9]-[0-3][0-9]-.+\\.[a-z]\\{2\\}\\.txt\\'" | ||
. gentoo-newsitem-mode)) | ||
(add-to-list 'auto-mode-alist '("/glep.*\\.rst\\'" . glep-mode)) | ||
(add-to-list 'auto-mode-alist | ||
'("/\\(package\\.\\(use\\|env\ | ||
\\|license\\|properties\\|accept_\\(keywords\\|restrict\\)\\)\ | ||
\\|\\(package\\.\\)?use.\\(stable\\.\\)?\\(force\\|mask\\)\\)\\'" | ||
. conf-mode)) | ||
(add-to-list 'interpreter-mode-alist '("openrc-run" . sh-mode)) | ||
(add-to-list 'interpreter-mode-alist '("runscript" . sh-mode)) | ||
(modify-coding-system-alist 'file "\\.\\(ebuild\\|eclass\\)\\'" 'utf-8) |