Skip to content

Commit

Permalink
app-accessibility/espeak-ng: new package, replaces app-accessibility/…
Browse files Browse the repository at this point in the history
…espeak

Package-Manager: Portage-3.0.20, Repoman-3.0.2
Signed-off-by: William Hubbs <[email protected]>
  • Loading branch information
williamh committed Jun 30, 2021
1 parent d0faa61 commit 26f1515
Show file tree
Hide file tree
Showing 3 changed files with 105 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-accessibility/espeak-ng/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST espeak-ng-1.50.tar.gz 13665536 BLAKE2B c64c2a474374d4b6fe13bf3a99f5dfb661923c13ebd6c0bc323e7f26d9d90945c7075cc5c8f4b51e5db3303632c8c9daca7a65a1883e09d7c3faf63dd725ea3f SHA512 297dd80a6cdae3e2b8acf6823475220ce89d6a5fb68ea303156ad52cb3e7388049b6921759d4ed4e3d2e2ebd19bf931259e454f74a2ac0b7ecf4ce56c1d60c0c
80 changes: 80 additions & 0 deletions app-accessibility/espeak-ng/espeak-ng-1.50.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,80 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools

DESCRIPTION="Software speech synthesizer for English, and some other languages"
HOMEPAGE="https://github.com/espeak-ng/espeak-ng"
SRC_URI="https://github.com/espeak-ng/espeak-ng/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3+ Turkowski unicode"
SLOT="0"
KEYWORDS="~amd64"
IUSE="+async +klatt l10n_ru l10n_zh man mbrola +sound"

COMMON_DEPEND="
!app-accessibility/espeak
mbrola? ( app-accessibility/mbrola )
sound? ( media-libs/pcaudiolib )
"
DEPEND="${COMMON_DEPEND}"
RDEPEND="${COMMON_DEPEND}
sound? ( media-sound/sox )
"
BDEPEND="
virtual/pkgconfig
man? ( app-text/ronn )
"

DOCS=( CHANGELOG.md README.md docs )

src_prepare() {
default

# disable failing tests
rm tests/{language-pronunciation,translate}.test || die
sed -i \
-e "/language-pronunciation.check/d" \
-e "/translate.check/d" \
Makefile.am || die

# https://github.com/espeak-ng/espeak-ng/issues/699
# fixed in master
sed -i -e "s/int samplerate;/static int samplerate;/" src/espeak-ng.c || die

eautoreconf
}

src_configure() {
local econf_args
econf_args=(
$(use_with async)
$(use_with klatt)
$(use_with l10n_ru extdict-ru)
$(use_with l10n_zh extdict-zh)
$(use_with l10n_zh extdict-zhy)
$(use_with mbrola)
$(use_with sound pcaudiolib)
--without-libfuzzer
--without-sonic
--disable-rpath
--disable-static
)
econf "${econf_args[@]}"
}

src_compile() {
# see docs/building.md
emake -j1
}

src_test() {
emake check
}

src_install() {
emake DESTDIR="${D}" VIMDIR=/usr/share/vimfiles install
rm "${ED}"/usr/lib*/*.la || die
}
24 changes: 24 additions & 0 deletions app-accessibility/espeak-ng/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<upstream>
<maintainer>
<name>Reece H. Dunn</name>
<email>[email protected]</email>
</maintainer>
<remote-id type="github">espeak-ng/espeak-ng</remote-id>
<changelog>https://github.com/espeak-ng/espeak-ng/releases.atom</changelog>
</upstream>
<maintainer type="person">
<email>[email protected]</email>
<name>William Hubbs</name>
</maintainer>
<use>
<flag name="async">Enables asynchronous commands</flag>
<flag name="klatt">Enables Klatt formant synthesis and implementation</flag>
<flag name="l10n_ru">Builds extended Russian Dictionary file</flag>
<flag name="l10n_zh">Builds extended Chinese (Mandarin and Cantonese) Dictionary files</flag>
<flag name="man">Builds and installs manpage with app-text/ronn</flag>
<flag name="mbrola">Adds support for mbrola voices</flag>
</use>
</pkgmetadata>

0 comments on commit 26f1515

Please sign in to comment.