Skip to content

Commit

Permalink
dev-php/pecl-memcached: revbump to fix incorrect DOCS.
Browse files Browse the repository at this point in the history
The main reason for a revision bump is to update the DOCS string
(which pointed to a missing file). This is a prerequisite for fixing
the buggy eclass that allows junk in DOCS.

In the process, some other cleanup was done:

  * Change from EAPI=4 to EAPI=5.
  * Add ChangeLog and README.markdown as DOCS.
  * Reorder the USE_PHP flags.
  * Drop the base.eclass inherit (this was used to apply patches).
  * Drop the custom src_prepare (used to call base.eclass to apply patches).
  * Add an "any slot" dependency on dev-lang/php.
  * Shorten the description a little to fit in 80 chars.

Package-Manager: portage-2.2.20.1
  • Loading branch information
orlitzky committed Dec 7, 2015
1 parent 444e0ba commit 27f68d7
Showing 1 changed file with 36 additions and 0 deletions.
36 changes: 36 additions & 0 deletions dev-php/pecl-memcached/pecl-memcached-2.2.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PHP_EXT_NAME="memcached"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
DOCS="ChangeLog README.markdown"

USE_PHP="php5-4 php5-5 php5-6"

inherit php-ext-pecl-r2

KEYWORDS="~amd64 ~x86"

DESCRIPTION="Interface PHP with memcached via libmemcached library"
LICENSE="PHP-3"
SLOT="0"
IUSE="+session igbinary json sasl"

DEPEND="|| ( >=dev-libs/libmemcached-1.0.14 >=dev-libs/libmemcached-1.0[sasl?] )
sys-libs/zlib
dev-lang/php:*[session?,json?]
igbinary? ( dev-php/igbinary[php_targets_php5-4?,php_targets_php5-5?,php_targets_php5-6?] )"
RDEPEND="${DEPEND}"

src_configure() {
my_conf="--enable-memcached
$(use_enable session memcached-session)
$(use_enable sasl memcached-sasl)
$(use_enable json memcached-json)
$(use_enable igbinary memcached-igbinary)"

php-ext-source-r2_src_configure
}

0 comments on commit 27f68d7

Please sign in to comment.