Skip to content

Commit

Permalink
games-util/linux-wbfs-manager: EAPI 5->8, update SRC_URI
Browse files Browse the repository at this point in the history
Also remove 9999 cruft due to live ebuild removal, and add .desktop.

Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
ionenwks committed Aug 3, 2021
1 parent 59583f9 commit 2817012
Showing 1 changed file with 12 additions and 31 deletions.
43 changes: 12 additions & 31 deletions games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild
Original file line number Diff line number Diff line change
@@ -1,51 +1,32 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5
EAPI=8

inherit toolchain-funcs

if [[ "${PV}" == "9999" ]]; then
ESVN_REPO_URI="https://linux-wbfs-manager.googlecode.com/svn/trunk/"
inherit subversion
SRC_URI=""
else
SRC_URI="https://linux-wbfs-manager.googlecode.com/files/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi;
inherit desktop toolchain-funcs

DESCRIPTION="WBFS manager for Linux using GTK+"
HOMEPAGE="https://code.google.com/p/linux-wbfs-manager/"
SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/linux-wbfs-manager/${P}.tar.gz"
S="${WORKDIR}/${PN}"

LICENSE="GPL-2"
SLOT="0"
IUSE=""
KEYWORDS="~amd64 ~x86"

RDEPEND="dev-libs/glib:2
RDEPEND="
dev-libs/glib:2
gnome-base/libglade:2.0"
DEPEND="${RDEPEND}
virtual/pkgconfig
"

if [[ ${PV} == "9999" ]] ; then
S=${WORKDIR}/${ECVS_MODULE}
else
S=${WORKDIR}/${PN}
fi

src_unpack() {
if [[ ${PV} == "9999" ]]; then
subversion_src_unpack
else
default
fi
}
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"

src_compile() {
emake CC="$(tc-getCC)"
}

src_install() {
dobin wbfs_gtk
dodoc README
einstalldocs

make_desktop_entry wbfs_gtk "WBFS manager" applications-utilities
}

0 comments on commit 2817012

Please sign in to comment.