Skip to content

Commit

Permalink
media-sound/gmpc: Port to EAPI 7
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
SoapGentoo committed Dec 12, 2019
1 parent a1d42df commit 2840174
Show file tree
Hide file tree
Showing 2 changed files with 38 additions and 26 deletions.
11 changes: 11 additions & 0 deletions media-sound/gmpc/files/gmpc-11.8.16-AM_CONFIG_HEADER.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- a/configure.ac
+++ b/configure.ac
@@ -14,7 +14,7 @@



-AM_CONFIG_HEADER([config.h])
+AC_CONFIG_HEADERS([config.h])
AC_CONFIG_MACRO_DIR([m4])
AM_INIT_AUTOMAKE

53 changes: 27 additions & 26 deletions media-sound/gmpc/gmpc-11.8.16-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,10 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=4
VALA_MIN_API_VERSION=0.12
EAPI=7

inherit autotools eutils gnome2-utils vala
inherit autotools vala xdg

DESCRIPTION="A GTK+2 client for the Music Player Daemon"
HOMEPAGE="http://gmpc.wikia.com/wiki/Gnome_Music_Player_Client"
Expand All @@ -13,32 +12,38 @@ SRC_URI="http://download.sarine.nl/Programs/gmpc/11.8/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="nls xspf +unique"

RDEPEND="dev-db/sqlite:3
>=dev-libs/glib-2.16:2
dev-libs/libxml2:2
>=media-libs/libmpd-11.8
net-libs/libsoup:2.4
>=x11-libs/gtk+-2.18:2
IUSE="nls +unique xspf"

RDEPEND="
dev-db/sqlite:3=
dev-libs/glib:2
dev-libs/libxml2:2=
media-libs/libmpd:=
net-libs/libsoup:2.4=
x11-libs/gtk+:2
x11-libs/libX11
x11-themes/hicolor-icon-theme
unique? ( dev-libs/libunique:1 )
xspf? ( >=media-libs/libxspf-1.2 )"
DEPEND="${RDEPEND}
unique? ( dev-libs/libunique:1= )
xspf? ( media-libs/libxspf:= )"
DEPEND="${RDEPEND}"
BDEPEND="
$(vala_depend)
app-text/gnome-doc-utils
>=dev-util/gob-2.0.17
dev-util/gob
virtual/pkgconfig
nls? ( dev-util/intltool
sys-devel/gettext )"
nls? (
dev-util/intltool
sys-devel/gettext
)"

DOCS=( AUTHORS README )
PATCHES=(
"${FILESDIR}"/${P}-underlinking.patch
"${FILESDIR}"/${P}-icons.patch
"${FILESDIR}"/${P}-AM_CONFIG_HEADER.patch
)

src_prepare() {
epatch "${FILESDIR}"/${P}-underlinking.patch \
"${FILESDIR}"/${P}-icons.patch
sed -i -e "s:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:" configure.ac || die
xdg_src_prepare
eautoreconf
vala_src_prepare
}
Expand All @@ -53,7 +58,3 @@ src_configure() {
$(use_enable unique) \
$(use_enable xspf libxspf)
}

pkg_preinst() { gnome2_icon_savelist; }
pkg_postinst() { gnome2_icon_cache_update; }
pkg_postrm() { gnome2_icon_cache_update; }

0 comments on commit 2840174

Please sign in to comment.