Skip to content

Commit

Permalink
dev-ada/langkit: add -lgnarl & -lgnat for incoming gprbuild
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Alfredo Tupone <[email protected]>
  • Loading branch information
atupone committed Jun 9, 2020
1 parent cfd22be commit 2920b98
Show file tree
Hide file tree
Showing 2 changed files with 62 additions and 0 deletions.
10 changes: 10 additions & 0 deletions dev-ada/langkit/files/langkit-2019-gnarl.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,10 @@
--- a/langkit/templates/mains_project_file.mako 2020-06-09 09:34:36.677265457 +0200
+++ b/langkit/templates/mains_project_file.mako 2020-06-09 09:35:30.569451995 +0200
@@ -40,4 +40,7 @@
for Switches ("ada") use ("-E");
end Binder;

+ package Linker is
+ for Switches ("ada") use ("-lgnat", "-lgnarl");
+ end Linker;
end Mains;
52 changes: 52 additions & 0 deletions dev-ada/langkit/langkit-2019-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python2_7 )

inherit python-single-r1 multiprocessing

MYP=${P}-20190510-19B8C

DESCRIPTION="A Python framework to generate language parsers"
HOMEPAGE="https://www.adacore.com/community"
SRC_URI="http://mirrors.cdn.adacore.com/art/5cdf8f8a31e87a8f1c967d31
-> ${MYP}-src.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="${PYTHON_DEPS}
dev-ada/gnatcoll-bindings[iconv,shared]
dev-python/mako
dev-python/pyyaml
dev-python/enum34
dev-python/funcy
dev-python/docutils"

DEPEND="${RDEPEND}
test? ( dev-ada/gnatcoll-bindings[gmp] )"

S="${WORKDIR}"/${MYP}-src

PATCHES=(
"${FILESDIR}"/${P}-gentoo.patch
"${FILESDIR}"/${P}-pyyaml.patch
"${FILESDIR}"/${P}-gnarl.patch
)

src_test() {
testsuite/testsuite.py -j $(makeopts_jobs) --show-error-output | tee testsuite.log
grep -q FAILED testsuite.log && die "Test failed"
}

src_install() {
default
python_domodule langkit
python_doscript scripts/create-project.py
}

0 comments on commit 2920b98

Please sign in to comment.