Skip to content

Commit

Permalink
net-mail/automx2: Bump to version 2021.3.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.17, Repoman-3.0.2
Signed-off-by: Ralph Seichter <[email protected]>
Closes: gentoo#20238
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
rseichter authored and thesamesam committed Apr 9, 2021
1 parent f3a6d00 commit 29884e5
Show file tree
Hide file tree
Showing 2 changed files with 50 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-mail/automx2/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST automx2-2021.0.tar.bz2 50912 BLAKE2B de6fe1ea6dd5223518683220ff1210baa68c30e67f9cd3aac1a965759cb0f72c1119427043579fb805f68457ac4062000cf8066b6fa6d7106f3ee7f777346a57 SHA512 3ca632cc71d64a9d9d434a7109ab0f55e23e3babb6c1734689f89e5a83c9daa6666af9ce09cb5a0c14256bd6e19f6c5339bd3b3398db7b2d70ff3c6114ddb428
DIST automx2-2021.2.tar.gz 155311 BLAKE2B 6ace715e24a27a8e98f09920150bd5d6fef7567fa7c3884825140ea8eebebb1392dcfbfab2b5a464f7967adcf421af5997023a7d33f41036608948b59e58155f SHA512 89113d3a37ee66ae44f98d64480419e6c6b10662560a5319ca0f5522d6195a68f586ec94793c2212d859693a50455a8b43292dd859b912404b5abb2ddfc939b6
DIST automx2-2021.3.1.tar.gz 169574 BLAKE2B cc9fcb1f2009e4c7ee9d827b89dbc7e0e95002b2ee7e6e30f1e27edcef439198db8e1ea3435a124dae3f6af19e12bb9f535af57e02fd56dd12185077db50bba8 SHA512 842cc824a8c10ac86f1d8c1f12984035f58c5c935ab7e0e306ed639100f850b47b65f911328f2d391f20dd2e7fad7c0eb6c533b2f2e1776261cffc934e8ae10a
49 changes: 49 additions & 0 deletions net-mail/automx2/automx2-2021.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{7,8,9} )

inherit distutils-r1

DESCRIPTION="Email client autoconfiguration service"
HOMEPAGE="https://automx.org/"
SRC_URI="https://github.com/rseichter/automx2/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64"
IUSE="doc"

BDEPEND="acct-user/automx2"
RDEPEND="
dev-python/flask[${PYTHON_USEDEP}]
dev-python/flask-migrate[${PYTHON_USEDEP}]
dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
dev-python/ldap3[${PYTHON_USEDEP}]
"

distutils_enable_tests unittest

python_prepare_all() {
sed -i -e "/('scripts'/d" setup.py || die
distutils-r1_python_prepare_all
}

python_test() {
export AUTOMX2_CONF="tests/unittest.conf"
${EPYTHON} -m unittest discover tests/ || die "Tests failed with ${EPYTHON}"
}

python_install_all() {
if use doc; then
DOCS="*.adoc doc/*.adoc contrib/*sample.conf"
HTML_DOCS="doc/*.html doc/*.svg"
fi
sed -e "s/@EPYTHON@/${EPYTHON}/" "${FILESDIR}/init" | newinitd - "${PN}"
newconfd "${FILESDIR}/confd" "${PN}"
insinto /etc
newins "${FILESDIR}/conf" "${PN}.conf"
distutils-r1_python_install_all
}

0 comments on commit 29884e5

Please sign in to comment.