Skip to content

Commit

Permalink
dev-python/subunit: Version Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Oct 23, 2015
1 parent 92b0314 commit 298aeb9
Show file tree
Hide file tree
Showing 2 changed files with 95 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/subunit/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -6,3 +6,4 @@ DIST subunit-0.0.21.tar.gz 441691 SHA256 f12565cb0c6efdee4d96e9e640db4bcbfbede73
DIST subunit-0.0.6.tar.gz 388872 SHA256 98f5e72107322dc1c502543384e1ed790671d319a5096eab4f4d20641555de77 SHA512 79aa46a2cbdbe27bb1fcfa02a65bd10ba9ccf5013f9cbd8549d5aad304b8d451ed6a854b1b77415601aab8f6966b7004337634ea5e7bd8387dda8209781b118f WHIRLPOOL fd05cfed6e7cd50df57dfc3dd0c45bf955a033abf7c43849193a9f7515847eb7d2df5819e964407dac253c46ba5073f2bb1499a92a94a072591a4db4d5128c2b
DIST subunit-1.0.0.tar.gz 441964 SHA256 55dc2c1c22c650ad9f109516a72a9d37b986939de25b6195210724ce79ced0ba SHA512 082990e777667edb7d3666b554a1818a976369742a1ed9bbc47a9c59f97937c0619a315893f532e49c2cd798537b320ca2aa9df916906b85a75db8a7d4f8bc84 WHIRLPOOL e6650f991ecb0c7d0fc6001947cc5f11740c34783e62485bf5e8acebc9369665a8658789c7b7df5608efe8c5931b263952383231e8989f3be98cca2a807ba471
DIST subunit-1.1.0.tar.gz 441946 SHA256 4869a5bec96b7b4e760d053f842d80548008740cda1a7efbb9053063ee818a51 SHA512 11aaa8f2ae04232623fbfb7b9561aa15bddbc55201a3a16eea1319a076de3417977590c57bb7ab0bbd86b321b203241ba5ea8050932759aeb3f3ed71b723a98b WHIRLPOOL 2705fcb98d0b67b5d2cddff87095a9b65782467f3e9b84f956ac29c85c2995881dcd63468a144277fb76b7adfdbbb2ecdc36eae8413886a72028e3565edbdf47
DIST subunit-1.2.0.tar.gz 460532 SHA256 27f0561297a7d56d85a8f5491f47e44303d0bb1d99c5627486774ea1bcb3d5c3 SHA512 f6559fd771ad0732985230d11a9a8326ef35c817b62d1f50dc332f0032f7b08559a46d2534983b7d3964e45682ac49b3e348581ee0983861390abcd4ec20459c WHIRLPOOL c30b4a2c9ab17f49f87e206fe5833ae564452b99af447f8c4cbf969b2f2dd96e482fc583e84264be815b051b1bd12e6c132cd779c88d0d68da53956fef0b25b7
94 changes: 94 additions & 0 deletions dev-python/subunit/subunit-1.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,94 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )

inherit distutils-r1 eutils multilib-minimal versionator

DESCRIPTION="A streaming protocol for test results"
HOMEPAGE="https://launchpad.net/subunit https://pypi.python.org/pypi/python-subunit"
SRC_URI="https://launchpad.net/${PN}/trunk/$(get_version_component_range 1-2)/+download/${P}.tar.gz"

LICENSE="Apache-2.0 BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="static-libs test"

RDEPEND="
>=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
dev-python/extras[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
dev-lang/perl:=
>=dev-libs/check-0.9.11[${MULTILIB_USEDEP}]
>=dev-util/cppunit-1.13.2[${MULTILIB_USEDEP}]
>=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
test? (
dev-python/fixtures[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/testscenarios[${PYTHON_USEDEP}]
)"

# Take out rogue & trivial failing tests that exit the suite before it even gets started
# The removed class in fact works fine in py3 and fails with py2.7 & pupu
# The setu to restrict this patch is just those 2 is not worth it.
PATCHES=( "${FILESDIR}"/1.0.0-tests.patch )

src_prepare() {
sed -i -e 's/os.chdir(os.path.dirname(__file__))//' setup.py || die

# Install perl modules in vendor_perl, bug 534654.
export INSTALLDIRS=vendor

# needed for perl modules
distutils-r1_src_prepare
multilib_copy_sources
}

multilib_src_configure() {
ECONF_SOURCE=${S} \
econf \
--enable-shared \
$(use_enable static-libs static)
}

multilib_src_compile() {
default
multilib_is_native_abi && distutils-r1_src_compile
}

python_test() {
local -x PATH="${PWD}/shell/share:${PATH}"
local -x PYTHONPATH=python
# Following tests are known to fail in py2.7 & pypy. They pass under py3.
# DO NOT re-file
# test_add_error test_add_error_details test_add_expected_failure
# test_add_expected_failure_details test_add_failure test_add_failure
# https://bugs.launchpad.net/subunit/+bug/1436686

"${PYTHON}" -m testtools.run all_tests.test_suite || die "Testing failed with ${EPYTHON}"
}

multilib_src_test() {
multilib_is_native_abi && distutils-r1_src_test
}

multilib_src_install() {
local targets=(
install-include_subunitHEADERS
install-pcdataDATA
install-exec-local
install-libLTLIBRARIES
)
emake DESTDIR="${D}" "${targets[@]}"

multilib_is_native_abi && distutils-r1_src_install
}

multilib_src_install_all() {
einstalldocs
prune_libtool_files
}

0 comments on commit 298aeb9

Please sign in to comment.