Skip to content

Commit

Permalink
dev-libs/geoip: Version bump.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
  • Loading branch information
Jeroen Roovers committed Nov 1, 2015
1 parent 01be0da commit 29ac06e
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/geoip/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST geoip-1.6.5.tar.gz 156441 SHA256 4a151b35e9d9db976b82645c758662a6cb778c669b2c65635d5834e4f885942e SHA512 1ed223a51d238b6bd8d247e1dcb20f6eb9e3f19d39bd262f7cbefb587ea029ed0abac540208916f3ca06bb86f9ea1e99614484fd1c32535892029e945471e702 WHIRLPOOL ca8cd55e16c9981b443fad9f788dc8f28a64dba86980740efeffaa9c4a9d5da84df8a23fb3710ef13741bb40bec0704ca80991e25d3b11fe10acd5a360c02d77
DIST geoip-1.6.6.tar.gz 156796 SHA256 db8ed5d07292c75cb3018738e6411037f15cc2a517f38ee04c1232cbe3d30b46 SHA512 4cdd308500bcb827b3dd1c6d981299ea746251758b6a5df97bf2cf098b62b0a736394d5853a06c62437eb0808cb54efb14d0579f5212284f29016e3c8cdd9846 WHIRLPOOL 518749339b094c4166ab53d8ec38020c72f1550923e8c0084f438391dfe7965a9b2f7b3e27ef5ecac85a3f62aa14299e11fbd740ea103c320eef5fad357994b2
DIST geoip-1.6.7.tar.gz 158276 SHA256 6f0ee5cd63660a2ab3a8f30df8e7246ee87b0eb33c719843d691c8d010cbabb5 SHA512 dde9ef65328297604892533ef5d5b568184eb4a29ff95839cb5e39b6652bcfbc53bf64fbcc3b55dad43cf0fca16f5611dbd96ba50f3001d8e212392304bce0b5 WHIRLPOOL 2d7e3b94317aa820c55c08be1808b9cc6d8cc38e87733cb1da3c9b3a5bf51212933e266ca105aabd765a08fe87f79f22eae5d8c6e3015a43fc923637273d6795
52 changes: 52 additions & 0 deletions dev-libs/geoip/geoip-1.6.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit autotools eutils

DESCRIPTION="easily lookup countries by IP addresses, even when Reverse DNS entries don't exist"
HOMEPAGE="https://github.com/maxmind/geoip-api-c"
SRC_URI="
https://github.com/maxmind/${PN}-api-c/archive/v${PV}.tar.gz -> ${P}.tar.gz
"

# GPL-2 for md5.c - part of libGeoIPUpdate, MaxMind for GeoLite Country db
LICENSE="LGPL-2.1 GPL-2 MaxMind2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
IUSE="static-libs"
RESTRICT="test"

DEPEND="net-misc/wget"
RDEPEND="${DEPEND}"

S="${WORKDIR}/${PN}-api-c-${PV}"

src_prepare() {
eautoreconf
}

src_configure() {
econf $(use_enable static-libs static)
sed -e "s|@PREFIX@|${ROOT}|g" "${FILESDIR}"/geoipupdate-r5.sh > geoipupdate.sh || die
}

src_install() {
default

dodoc AUTHORS ChangeLog NEWS.md README*

prune_libtool_files

keepdir /usr/share/GeoIP

dosbin geoipupdate.sh
}

pkg_postinst() {
ewarn "WARNING: Databases are no longer installed by this ebuild."
elog "Don't forget to run 'geoipupdate.sh -f' (or geoipupdate from"
elog "net-misc/geoipupdate) to populate ${ROOT}/usr/share/GeoIP/"
elog "with geo-located IP address databases."
}

0 comments on commit 29ac06e

Please sign in to comment.