Skip to content

Commit

Permalink
app-emulation/phpvirtualbox: Version bump
Browse files Browse the repository at this point in the history
Gentoo-Bug: 587960

Package-Manager: portage-2.3.3
  • Loading branch information
Markos Chandras committed Dec 10, 2016
1 parent 4c2199b commit 2a62578
Show file tree
Hide file tree
Showing 2 changed files with 73 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/phpvirtualbox/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST phpvirtualbox-4.1-11.zip 2763347 SHA256 91a78c7dead035edf8138a363c6b3cb89d8
DIST phpvirtualbox-4.2-7.zip 3425805 SHA256 3dc078d7058d75aa5745f531a6d485a11fff18972df1a638a749f019e0196e4e SHA512 a066f127115a83c6061e8c0ff6447464818511f3ab7805c119f75ddc88459efd144d45fb358ce52959301f2f1a4f2609f7f42c2bb24213a5be98f2036085a81b WHIRLPOOL d6cf095b9768b7a9c0113c8df354dad124a0b2dc0a52e8518dfde230823c95dcad6b6e3df56cc41a4474b8b73cb281f3bfc91f417078e0b6f1136acd70dca4cf
DIST phpvirtualbox-4.3-0.zip 4231805 SHA256 e33eea5553fb134ba6a1203e33e212bc5764c05b28164dcc02c6d66af565c293 SHA512 fd49a6a4c79d75f37fd40d74743f295a148548373ab046cf1f31ef7b982008ea6b9d2838cdad2dc37a1d266ed630cd2ddb7f7423ea62af1e0f8f9f76a12c0e9d WHIRLPOOL 1c96ec2fe19092dabac9e04be596974cc4dbaa9993c34e76b938036e8e04c67dc4f4f344be8afd636d603a478ce0c85435a75f8d6cf59bbdc3a11c6fd575b6c1
DIST phpvirtualbox-5.0-3.zip 4092132 SHA256 8e23eee4ee36ff8cf765afb6842338e8ea8190956882ec0baa30f09ff4fe134b SHA512 b632ff3be2028bd011ce27b580996638dfc89e09350c459f16bd1c8c5c3eefbab93f42d7facfb99279eb2ee1c6a38854ea999654ca2090a39c7bfa0afa7fe2d5 WHIRLPOOL 38070a6935e3a4e5155f84db395c9e82603583957b26fcf166a654446052b15aa3d3b7653a9f7d56a33382dc82058e55413575e75c26b4c97f782bb868cc66e8
DIST phpvirtualbox-5.0-5.zip 4093766 SHA256 c80c423fda30e5795872c9b9adc68429deee5726e468729472a573c324303c05 SHA512 5478e4a5eb74786eb409a87e7c962c80df558655342f541dddceb7e4cf153a4e5f0bda9b83c2a8a921326f6210c2c3bd344c4a9ce30547f25acce5966c4d6135 WHIRLPOOL e1cd9e91f74e403ea38c099cbaec495fc56551757a75c7348673251846dd4d433d37d1147ba68b4df673efb6ff9ac3cdeb4457aa80af03ea791fc48d1eece5eb
72 changes: 72 additions & 0 deletions app-emulation/phpvirtualbox/phpvirtualbox-5.0.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,72 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

inherit versionator eutils webapp readme.gentoo

MY_PV="$(replace_version_separator 2 '-')"
MY_P="${PN}-${MY_PV}"

DESCRIPTION="Web-based administration for VirtualBox in PHP"
HOMEPAGE="https://sourceforge.net/projects/phpvirtualbox/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"

LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND="
dev-lang/php[session,unicode,soap,gd]
virtual/httpd-php:*
"
DEPEND="app-arch/unzip"

S="${WORKDIR}/${MY_P}"

DISABLE_AUTOFORMATTING="yes"
DOC_CONTENTS="
Local or remote virtualbox hosts must be compiled with
'vboxwebsrv' useflag and the respective init script
must be running to use this interface:
/etc/init.d/vboxwebsrv start
To enable the automatic startup mode feature uncomment the
following line in the config.php file:
var \$startStopConfig = true;
You should also add the /etc/init.d/vboxinit script to the
default runlevel on the virtualbox host:
\`rc-update add vboxinit default\`
If the server is on a remote host, than the script must be
copied manually from
'${FILESDIR}'/vboxinit-initd to
/etc/init.d/vboxinit on the remote host."

src_install() {
webapp_src_preinst

dodoc CHANGELOG.txt LICENSE.txt README.md
rm -f CHANGELOG.txt LICENSE.txt README.md

insinto "${MY_HTDOCSDIR}"
doins -r .

webapp_configfile "${MY_HTDOCSDIR}"/config.php-example
webapp_serverowned "${MY_HTDOCSDIR}"/config.php-example

webapp_src_install
if has_version app-emulation/virtualbox[vboxwebsrv] || \
has_version app-emulation/virtualbox-bin[vboxwebsrv]
then
newinitd "${FILESDIR}"/vboxinit-initd vboxinit
fi

readme.gentoo_create_doc
}

pkg_postinst() {
webapp_pkg_postinst
readme.gentoo_print_elog
}

0 comments on commit 2a62578

Please sign in to comment.