Skip to content

Commit

Permalink
app-arch/pax: switch to MirOS version #537522
Browse files Browse the repository at this point in the history
  • Loading branch information
vapier committed Mar 7, 2016
1 parent b655076 commit 2a7fdd6
Show file tree
Hide file tree
Showing 2 changed files with 56 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-arch/pax/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST pax-3.4-12.fc16.src.rpm 171016 SHA256 b86ca0556b12600d3dd4777900baae5118e71ce9e026e42e3bb51aed23853932 SHA512 78704cd1b66288acdaa8fdf4ca0a97c12b1e843e024be4d3fac88a6b42049928c6bfe69a72a58a00a9bf755c23e1e8e0b7d30bc72ba08a83830495dd5f6d9be1 WHIRLPOOL 8a674356efa939ceff0f502de926688d81f17da48c98f24674a76f11043f420c33aa9f47eb66fb1e896ddc4ca4c64cec554d7397379d1ccc884bf02b37eb9b29
DIST paxmirabilis-20160306.cpio.gz 147448 SHA256 4e36fabfabc01a15e0d01eee0306cef79a7f374586f46254dae139eb866ae81b SHA512 65c9613f235d973f23d829d87b93963f4b21beca4d7158abb8243f7f0ba8eb883544bbd0c16bde82f0e55ab2fbf33e3dfb155a50c0f5be3bf6d88eaf95e1037f WHIRLPOOL 5945f45cc69cfd25d7754a9b6b25db98170de2fc926ffe3a661402d95bc41517e40ff059998d682cc65e32fd7e70a78e222525012eb98dde54c1d67c0c6c2277
55 changes: 55 additions & 0 deletions app-arch/pax/pax-20160306.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

inherit unpacker toolchain-funcs

DESCRIPTION="pax (Portable Archive eXchange) is the POSIX standard archive tool"
HOMEPAGE="https://www.mirbsd.org/pax.htm"
SRC_URI="https://www.mirbsd.org/MirOS/dist/mir/cpio/paxmirabilis-${PV}.cpio.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE=""

RDEPEND="dev-libs/libbsd"
DEPEND="${RDEPEND}
$(unpacker_src_uri_depends)"

S=${WORKDIR}/${PN}

src_prepare() {
# Newer C libraries omit this include from sys/types.h.
sed -i '1i#include <sys/sysmacros.h>' extern.h || die
}

src_configure() {
tc-export CC PKG_CONFIG
}

src_compile() {
# We can't rely on LFS flags as it uses the fts.h interface which lacks 64-bit support.
set -- \
${CC} ${CPPFLAGS} ${CFLAGS} \
-DHAVE_STRLCPY -DHAVE_VIS -DHAVE_STRMODE \
-DLONG_OFF_T -DHAVE_LINKAT \
$(${PKG_CONFIG} --cflags libbsd-overlay) \
-Wall ${LDFLAGS} *.c -o ${PN} \
$(${PKG_CONFIG} --libs libbsd-overlay)
echo "$@"
"$@" || die
}

src_install() {
dobin ${PN}
doman ${PN}.1

dosym pax /usr/bin/paxcpio
newman cpio.1 paxcpio.1

dosym pax /usr/bin/paxtar
newman tar.1 paxtar.1
}

0 comments on commit 2a7fdd6

Please sign in to comment.