Skip to content

Commit

Permalink
gui-libs/wlroot: add 0.12.0
Browse files Browse the repository at this point in the history
* This adds 0.12.0
* No KEYWORDS as breaking changes have occurred and we want to prevent
  any skipped updates by the PM for unstable users.

Signed-off-by: Aaron Bauman <[email protected]>
  • Loading branch information
FuzzyGophers committed Nov 9, 2020
1 parent 396dc38 commit 2aa89c7
Show file tree
Hide file tree
Showing 2 changed files with 77 additions and 0 deletions.
1 change: 1 addition & 0 deletions gui-libs/wlroots/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST wlroots-0.10.0.tar.gz 454540 BLAKE2B 0d2326a62267019001be5f0d79c7b5c937ed20b952c92f0dd8cb04c3a0c06f3ef58723f552b1da1b947ea50ad91df46a543ec9705dad588db800bfa944743d11 SHA512 0e8e0c37f1afb1d99f0ecb3c2282992ffd06381aaa396c7234ead9f3ff2d5c599e766b677680ebaecf68e792054c3e42657d24f32d08bc8bcf35f9eb4bdaa876
DIST wlroots-0.10.1.tar.gz 455232 BLAKE2B 0f4def61d8501b7746ccc589d59586b3641340fb7633b0c4a7b518f1b1b5285c1ee71fb629aa0a0e649c15a4ae69b5cfbc7a034c96e545765a96ddda35f10609 SHA512 e1af5a5b6484b5f4060090e13d22d699d5aaa6926e1a6b1043d2b900f88a002ed67dacf8498f23ed3008bf8a35500f415f95b3dbcf50de5da354f309f9161d58
DIST wlroots-0.11.0.tar.gz 481126 BLAKE2B d2262298f24948293643b02c823851b4643289f776bc087d7b67240f4c9c76a7aca03c7dc7e13a65b3d0d3a7c8a5f5246a0e282d2cb3b88bbae0ef94b906f18a SHA512 a8a0c498d10664ff0a5aab8ad1a4fd034179542eff38b058e1da7e4653c42136e4a3586634f3d0a25a985aa7f4c5d17260117d9f4a70a7f8060494c04456f575
DIST wlroots-0.12.0.tar.gz 476936 BLAKE2B 4129c87a148085f95f4cee6973308d79ab3f8b024247287a68dadd6729da8a5f8cc1e4ada63c15477a2c8e8258032440afe4a21a26f947143d17c87b0ca8a1a4 SHA512 560eae30932b777c1f07fb44592d5601c5d10ef74b31b6b9e4166a14caadab2bfa88d39282f159785d4c7f22f78d204f9bb7fab65d58afaf14b72a8486f9b415
76 changes: 76 additions & 0 deletions gui-libs/wlroots/wlroots-0.12.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit fcaps meson

DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
HOMEPAGE="https://github.com/swaywm/wlroots"

if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
inherit git-r3
else
SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS=""
fi

LICENSE="MIT"
SLOT="0/12"
IUSE="elogind icccm systemd x11-backend X"
REQUIRED_USE="?? ( elogind systemd )"

DEPEND="
>=dev-libs/libinput-1.9.0:0=
>=dev-libs/wayland-1.18.0
>=dev-libs/wayland-protocols-1.17.0
media-libs/mesa[egl,gles2,gbm]
virtual/libudev
x11-libs/libdrm
x11-libs/libxkbcommon
x11-libs/pixman
elogind? ( >=sys-auth/elogind-237 )
icccm? ( x11-libs/xcb-util-wm )
systemd? ( >=sys-apps/systemd-237 )
x11-backend? ( x11-libs/libxcb:0= )
X? (
x11-base/xorg-server[wayland]
x11-libs/libxcb:0=
x11-libs/xcb-util-image
)
"
RDEPEND="
${DEPEND}
"
BDEPEND="
>=dev-libs/wayland-protocols-1.17
>=dev-util/meson-0.54.0
virtual/pkgconfig
"

src_configure() {
# xcb-util-errors is not on Gentoo Repository (and upstream seems inactive?)
local emesonargs=(
"-Dxcb-errors=disabled"
-Dxcb-icccm=$(usex icccm enabled disabled)
-Dxwayland=$(usex X enabled disabled)
-Dx11-backend=$(usex x11-backend enabled disabled)
"-Dexamples=false"
"-Dwerror=false"
)
if use systemd; then
emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")
elif use elogind; then
emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=elogind")
else
emesonargs+=("-Dlogind=disabled")
fi

meson_src_configure
}

pkg_postinst() {
elog "You must be in the input group to allow your compositor"
elog "to access input devices via libinput."
}

0 comments on commit 2aa89c7

Please sign in to comment.