Skip to content

Commit

Permalink
dev-ruby/rjb: add 1.5.4
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
graaff committed Nov 29, 2015
1 parent c1e909f commit 2af35a3
Show file tree
Hide file tree
Showing 2 changed files with 83 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/rjb/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST rjb-1.5.3.gem 73216 SHA256 e47da10ab3c784fb1a03929832d31ae850bac1c3b6fabc890e28cda79a48fa3f SHA512 fa18a810a938a70920825f79665730152c6e6b9f9fa97949bac6f4920bb2a9f2fd27ad31edd790757db4c06b33f3558a2a7584592a22692de07614c17d65130f WHIRLPOOL 3401d9400916971d5ea8acdcab0a5587f7ac44f52d0f0b951fba20b35d0b1a125a998d070ce35967f2fe62c7d8140fb904296f25cb1032571727b845bada0e37
DIST rjb-1.5.4.gem 73216 SHA256 81df90c028dccd758e8b38c8b7d80620d23ebb5c355233b82c4cacfe85cb4851 SHA512 add7268f3320e4627b8b92103f420cd5be03319c54cdf0478980631ab57523ed9dd190f7a535b5bc9892d42b049712c18b406bacb36212f8cfb6ce5f3c74766d WHIRLPOOL bc0feabe46b63b4a1ccd0e2f88c72e24068737ba96ed3e52482921318e5fed8453a798bca5e5001eb815c4e74d3870f70343ce792764bef03f43350062214103
82 changes: 82 additions & 0 deletions dev-ruby/rjb/rjb-1.5.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,82 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

USE_RUBY="ruby20 ruby21 ruby22"

RUBY_FAKEGEM_EXTRADOC="readme.txt ChangeLog"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_TASK_TEST=""

RUBY_FAKEGEM_EXTRAINSTALL="data"

inherit java-pkg-2 ruby-ng ruby-fakegem

DESCRIPTION="Rjb is a Ruby-Java software bridge"
HOMEPAGE="https://github.com/arton/rjb"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples hardened"

DEPEND=">=virtual/jdk-1.5
hardened? ( sys-apps/paxctl )"
RDEPEND="virtual/jre"

pkg_setup() {
ruby-ng_pkg_setup
java-pkg-2_pkg_setup
}

all_ruby_prepare() {
# The console is not available for testing.
sed -i -e '/test_noarg_sinvoke/,/end/ s:^:#:' test/test.rb || die

# Avoid encoding tests since not all locales may be available.
sed -i -e '/test_kjconv/,/^ end/ s:^:#:' test/test.rb || die
}

each_ruby_prepare() {
#dev-lang/ruby might need the "hardened" flag to enforce the following:
if use hardened; then
paxctl -v /usr/bin/ruby 2>/dev/null | grep MPROTECT | grep disabled || ewarn '!!! rjb will only work if ruby is MPROTECT disabled\n please disable it if required using paxctl -m /usr/bin/ruby'
fi
# force compilation of class file for our JVM
rm -rf data
}

each_ruby_configure() {
${RUBY} -C ext extconf.rb || die "extconf.rb failed"
}

each_ruby_compile() {
emake V=1 -C ext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}"
}

each_ruby_install() {
each_fakegem_install

# currently no elegant way to do this (bug #352765)
ruby_fakegem_newins ext/rjbcore.so lib/rjbcore.so

if use examples; then
insinto /usr/share/doc/${PF}
doins -r samples
fi
}

each_ruby_test() {
if use hardened; then
paxctl -v ${RUBY} 2>/dev/null | grep MPROTECT | grep -q disabled
if [ $? = 0 ]; then
${RUBY} -C test -I../lib:.:../ext test.rb || die
else
ewarn "${RUBY} has MPROTECT enabled, rjb will not work until it is disabled, skipping tests."
fi
else
${RUBY} -C test -I../lib:.:../ext test.rb || die
fi
}

0 comments on commit 2af35a3

Please sign in to comment.