Skip to content

Commit

Permalink
app-xemacs/ebuild-mode: Version bump to 1.50.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.92, Repoman-2.3.20
Signed-off-by: Ulrich Müller <[email protected]>
  • Loading branch information
ulm committed Mar 7, 2020
1 parent dbdb540 commit 2b2ad87
Show file tree
Hide file tree
Showing 2 changed files with 37 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-xemacs/ebuild-mode/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST ebuild-mode-1.49.tar.xz 34632 BLAKE2B 3e7814363aedbb5a05193faccc0815a7f4b0f56eacb03fb720fa270ac69faa163bd8164639390b1703bb0a82341975e9bfea143c651b5b0ba2825b2bbb3b3329 SHA512 440e23aa6f63307955a9c970f5cbcc175eb14cca4ff4035da4f10fa22d9c6766b29ca7842b800a43c46063f3045c2ff3b2d6b8e27026f47bd0ed0959a8f2d0e9
DIST ebuild-mode-1.50.tar.xz 35440 BLAKE2B 281719a0a686ef1c80c8391cc118d14085ac6407dee5ee7ee44229bb529de041d31fcec7c08bb1e4b8b5057823c5d99a49a9786daa0b7b17a766155b7daaaecc SHA512 a7c232103848c7782a4ebad89e064f3bc37a78427228be799d8e1bd3670524b32050229ba7cd48d9e4c2b0bb32828ce95eb2e47038411591d03fa8f998614c1e
36 changes: 36 additions & 0 deletions app-xemacs/ebuild-mode/ebuild-mode-1.50.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"

RDEPEND=">=app-editors/xemacs-21.4.20-r5
app-xemacs/sh-script"
BDEPEND="${RDEPEND}"

src_compile() {
local XEMACS="${EPREFIX}/usr/bin/xemacs"

"${XEMACS}" -batch -q --no-site-file \
-eval "(add-to-list 'load-path \".\")" \
-f batch-byte-compile \
ebuild-mode.el gentoo-newsitem-mode.el || die

"${XEMACS}" -batch -q --no-site-file \
-eval "(setq autoload-package-name \"${PN}\")" \
-eval "(setq generated-autoload-file \"${S}/auto-autoloads.el\")" \
-l autoload -f batch-update-autoloads \
ebuild-mode.el gentoo-newsitem-mode.el || die
}

src_install() {
insinto /usr/share/xemacs/site-packages/lisp/${PN}
doins *.el *.elc
}

0 comments on commit 2b2ad87

Please sign in to comment.