Skip to content

Commit

Permalink
games-board/xboard: tweak for gcc-10
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <[email protected]>
  • Loading branch information
Sergei Trofimovich committed Jan 21, 2020
1 parent a629600 commit 2c5ad14
Show file tree
Hide file tree
Showing 2 changed files with 34 additions and 1 deletion.
32 changes: 32 additions & 0 deletions games-board/xboard/files/xboard-4.9.1-gcc-10.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
--- a/backend.h
+++ b/backend.h
@@ -242,7 +242,7 @@ extern GameInfo gameInfo;

/* ICS vars used with backend.c and zippy.c */
enum ICS_TYPE { ICS_GENERIC, ICS_ICC, ICS_FICS, ICS_CHESSNET /* not really supported */ };
-enum ICS_TYPE ics_type;
+extern enum ICS_TYPE ics_type;

/* pgntags.c prototypes
*/
--- a/evalgraph.h
+++ b/evalgraph.h
@@ -34,7 +34,7 @@ typedef enum { PEN_NONE, PEN_BLACK, PEN_DOTTED, PEN_BLUEDOTTED, PEN_BOLDWHITE, P
#define OPEN 0

/* Module globals */
-ChessProgramStats_Move * currPvInfo;
+extern ChessProgramStats_Move * currPvInfo;
extern int currFirst;
extern int currLast;
extern int currCurrent;
--- a/xaw/xhistory.c
+++ b/xaw/xhistory.c
@@ -96,7 +96,6 @@ ScrollToCursor (Option *opt, int caretPos)

// ------------------------------ callbacks --------------------------

-char *historyText;
char historyTranslations[] =
"<Btn3Down>: select-start() \n \
<Btn3Up>: extend-end(PRIMARY) SelectMove() \n";
3 changes: 2 additions & 1 deletion games-board/xboard/xboard-4.9.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2019 Gentoo Authors
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
Expand Down Expand Up @@ -43,6 +43,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-4.8.0-gettext.patch
"${FILESDIR}"/${PN}-4.8.0-gnuchess-default.patch
"${FILESDIR}"/${PN}-4.9.1-gcc-10.patch
)

DOCS=( AUTHORS COPYRIGHT ChangeLog FAQ.html NEWS README TODO ics-parsing.txt )
Expand Down

0 comments on commit 2c5ad14

Please sign in to comment.