Skip to content

Commit

Permalink
dev-python/bandit: bup
Browse files Browse the repository at this point in the history
Signed-off-by: Matthew Thode <[email protected]>

Package-Manager: portage-2.2.20.1
  • Loading branch information
prometheanfire committed Aug 14, 2015
1 parent 922cabd commit 2ce7377
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/bandit/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST bandit-0.12.0.tar.gz 65558 SHA256 3c147b507696f3a74a5cf3581cc3bb65a63df454fcf24db28c3d1baa765a3b04 SHA512 ef1d80f2ca09d427e6d48f983d696fb92eb12184fbdc13dfb170a73c5935f56f7e6bf3b4cf4d211598f884592e6fe2ca33f6d33732cf12e740f74d43ffe78457 WHIRLPOOL 1defd5dcb9d120585b10e72c51501373572e7d56c0e379ec587592fd53a381baf262a970956cd9fa4c2ad007697a1b7db9068d130b6cb3a33a00c40bb9c6a13c
DIST bandit-0.13.0.tar.gz 73142 SHA256 4593957b236564599dec7c8b2da5b084f9b257213688a3a97b2643c04721eb66 SHA512 1605fb2e3e43a85ccf89a0b18c517082543d20b55149383d3704d71854817cfef3fd5e1095dd58e24efe0324ca9430fc8d7ab9f3e4f1db1ca0ffe7c4f8e17577 WHIRLPOOL 3becc739b966c2ff550988f04b1dbb03b285b120ff1f2bf4822a0b2277bdd2dc23f7e5c4d5ce6ea98dc45211d9ee7ed52f37e602f2d18558eacce356b81f79a5
DIST bandit-0.13.1.tar.gz 68706 SHA256 e8383d751d0eacd0491e6821c6a176e317316ba3afd7005d11690467a091dd0c SHA512 c3d439f17c02b3ef24c52aa8044c414ffccb2e5e60b7d744d1ec20ff9aff40e6254626c032230da59ec2bf4d923bc16ef9f777b34a09b73cccb782b4f536d869 WHIRLPOOL c9f5ff8410f28fb361d50854b5e8750f3f71ce951e91d50570438282559c9fb92aadc38efb5b87b8d262a589ca5bcb2d8f410443a7d431c51729f310e64d217d
DIST bandit-0.13.2.tar.gz 68888 SHA256 ef78c4dda20f758f95aca467fbb6609a696b6df13104d324b329b1bca963e30d SHA512 0809b7bca2f88e579760c7dcd3fedd1bdd394930eb0cd203ec24d75a18cc8007fa0db304a378f2d99d9cfd5e8b1f34a4ebe427a4bcb5daadf3d29acf0a26da42 WHIRLPOOL c91c140a79816d55f46b4b81e8554e2e36ff47b217da0258cc8ca220b59fd1b0622bd938956280ee111ee994cee81a442da3148fc1be9f0ff8c7d1ea2cdc305d
52 changes: 52 additions & 0 deletions dev-python/bandit/bandit-0.13.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python2_7 python3_4 )

inherit distutils-r1

DESCRIPTION="A security linter from OpenStack Security"
HOMEPAGE="https://openstack.org"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

CDEPEND="
>=dev-python/pbr-1.3.0[${PYTHON_USEDEP}]
<dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"

DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
${CDEPEND}
test? (
>=dev-python/coverage-3.6[${PYTHON_USEDEP}]
>=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
>=dev-python/hacking-0.9.2[${PYTHON_USEDEP}]
<dev-python/hacking-0.10[${PYTHON_USEDEP}]
>=dev-python/mock-1.0[${PYTHON_USEDEP}]
>=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
>=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
>=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
>=dev-python/testtools-0.9.36[${PYTHON_USEDEP}]
!~dev-python/testtools-1.2.0[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
!~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
<dev-python/sphinx-1.3[${PYTHON_USEDEP}]
>=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
)"
RDEPEND="
${CDEPEND}
>=dev-python/appdirs-1.3.0[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]
>=dev-python/stevedore-1.5.0[${PYTHON_USEDEP}]"

python_test() {
testr init
testr run || die
}

0 comments on commit 2ce7377

Please sign in to comment.