forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Revert "dev-db/oracle-instantclient-odbc: cleanup old"
This reverts commit 99e250c. There have been stable keywords around.
- Loading branch information
Showing
3 changed files
with
216 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,4 @@ | ||
DIST instantclient-odbc-linux-11.2.0.3.0.zip 273840 BLAKE2B 54fd920bb69a12f2df387e89907c6c2a64f05fd611cb53737d6773752c3a08fbe4cb36cc43017a62e7861cd6245b4d92cbf635fabc921c0aeeaa8d00f9e012d5 SHA512 4d928e9eb3deb26db7a95a0e5417bd9355e97956d9394dc2792752fd45002b0abc3463fbb7f337f4731084aa6006d1ff635443c5503f94c6bd97d1bae7245885 | ||
DIST instantclient-odbc-linux-11.2.0.4.0.zip 274999 BLAKE2B 33855608fcd61a7f4ebcab3f969b028069d636d5a709676c07733aeb20dcb4335f485844ec72cb0816307e36c7f0b6748c08ea6e5c67c853999ddc1b0c23eae8 SHA512 64d75c6f9aa4e5b74da12a2a293e6ee7017017a12a724596d51606d3a8d7a9d9653c158d389a5faeb02893ca6a6a93650605d71f885f9439427847583f5cc820 | ||
DIST instantclient-odbc-linux.x64-11.2.0.3.0.zip 309061 BLAKE2B 9ddd2569364a383f525052d4c795c423ed4b44a588ec4e11e5f5130604b6d74b4ede2afdb326023d8a0167b1522669c9acc6f9e74928423f62d08c93404cd98d SHA512 a18c040fc780f893ea22fd6c79b3299d9327975a768a6518622a8ff522dd29a7019494ca7a1227483098f13afe1af1655611a32e06806bab94ab2fce2dc55e3a | ||
DIST instantclient-odbc-linux.x64-11.2.0.4.0.zip 310560 BLAKE2B dc97373ac00f07b4d02beb45ed053d5aa8909fc380990426c118e3fb42b08e8e5e699a518aa137b3fe159107c73929e61d59c997e741a343803f5c26036adf9b SHA512 19f999207e5ea2b5db18b40c0eb40c6ec1ea8a3117915a723338e5c423122b747c5e371446d631c00a5c01005453f85da1d2e680a2c1771a495dc0b68812df69 |
116 changes: 116 additions & 0 deletions
116
dev-db/oracle-instantclient-odbc/oracle-instantclient-odbc-11.2.0.3.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,116 @@ | ||
# Copyright 1999-2012 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="4" | ||
|
||
inherit eutils multilib | ||
|
||
MY_PLAT_x86="Linux x86" | ||
MY_A_x86="${PN/oracle-/}-linux-${PV}.0.zip" | ||
|
||
MY_PLAT_amd64="Linux x86-64" | ||
MY_A_amd64="${PN/oracle-/}-linux.x64-${PV}.0.zip" | ||
|
||
DESCRIPTION="Oracle 11g Instant Client: ODBC supplement" | ||
HOMEPAGE="http://www.oracle.com/technetwork/database/features/instant-client/index.html" | ||
SRC_URI=" | ||
x86? ( ${MY_A_x86} ) | ||
amd64? ( ${MY_A_amd64} multilib? ( ${MY_A_x86} ) ) | ||
" | ||
|
||
LICENSE="OTN" | ||
SLOT="0" | ||
KEYWORDS="amd64 x86" | ||
RESTRICT="fetch" | ||
IUSE="multilib" | ||
|
||
DEPEND="app-arch/unzip" | ||
RDEPEND="~dev-db/oracle-instantclient-basic-${PV}" | ||
|
||
S="${WORKDIR}" | ||
|
||
QA_PREBUILT="usr/lib*/oracle/${PV}/client/lib*/lib*" | ||
|
||
default_abi() { | ||
[[ ${DEFAULT_ABI} == 'default' ]] && echo ${ARCH} || echo ${DEFAULT_ABI} | ||
} | ||
|
||
abi_list() { | ||
if use multilib; then | ||
echo ${MULTILIB_ABIS} | ||
else | ||
default_abi | ||
fi | ||
return 0 | ||
} | ||
|
||
set_abivars() { | ||
local abi=$1 | ||
# platform name | ||
MY_PLAT=MY_PLAT_${abi} | ||
MY_PLAT=${!MY_PLAT} | ||
# runtime distfile | ||
MY_A=MY_A_${abi} | ||
MY_A=${!MY_A} | ||
# abi sourcedir | ||
MY_S="${S}/${abi}/instantclient_11_2" | ||
# ABI might not need to be set at all | ||
[[ -n ${ABI} ]] && MY_ABI=${abi} || MY_ABI= | ||
# abi libdir | ||
MY_LIBDIR=$(ABI=${MY_ABI} get_libdir) | ||
} | ||
|
||
pkg_nofetch() { | ||
eerror "Please go to" | ||
eerror " ${HOMEPAGE%/*}/index-097480.html" | ||
eerror " and download" | ||
local abi | ||
for abi in $(abi_list) | ||
do | ||
set_abivars ${abi} | ||
eerror "Instant Client for ${MY_PLAT}" | ||
eerror " ODBC: ${MY_A}" | ||
done | ||
eerror "After downloading, put them in:" | ||
eerror " ${DISTDIR}/" | ||
} | ||
|
||
src_unpack() { | ||
local abi | ||
for abi in $(abi_list) | ||
do | ||
set_abivars ${abi} | ||
mkdir -p "${MY_S%/*}" || die | ||
cd "${MY_S%/*}" || die | ||
unpack ${MY_A} | ||
done | ||
} | ||
|
||
src_install() { | ||
# all binaries go here | ||
local oracle_home=/usr/$(get_libdir)/oracle/${PV}/client | ||
into "${oracle_home}" | ||
|
||
local abi | ||
for abi in $(abi_list) | ||
do | ||
set_abivars ${abi} | ||
einfo "Installing runtime for ${MY_PLAT} ..." | ||
|
||
cd "${MY_S}" || die | ||
|
||
ABI=${MY_ABI} dolib.so libsqora*$(get_libname)* | ||
|
||
# ensure to be linkable | ||
[[ -e libsqora$(get_libname) ]] || | ||
dosym libsqora$(get_libname 11.1) \ | ||
"${oracle_home}"/${MY_LIBDIR}/libsqora$(get_libname) | ||
|
||
eend $? | ||
done | ||
|
||
set_abivars $(default_abi) | ||
cd "${MY_S}" || die | ||
dobin odbc_update_ini.sh | ||
dodoc *htm* | ||
} |
96 changes: 96 additions & 0 deletions
96
dev-db/oracle-instantclient-odbc/oracle-instantclient-odbc-11.2.0.4.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,96 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="4" | ||
|
||
inherit eutils multilib-minimal | ||
|
||
MY_PLAT_x86="Linux x86" | ||
MY_A_x86="${PN/oracle-/}-linux-${PV}.0.zip" | ||
|
||
MY_PLAT_amd64="Linux x86-64" | ||
MY_A_amd64="${PN/oracle-/}-linux.x64-${PV}.0.zip" | ||
|
||
DESCRIPTION="Oracle 11g Instant Client: ODBC supplement" | ||
HOMEPAGE="http://www.oracle.com/technetwork/database/features/instant-client/index.html" | ||
SRC_URI=" | ||
abi_x86_32? ( ${MY_A_x86} ) | ||
abi_x86_64? ( ${MY_A_amd64} ) | ||
" | ||
|
||
LICENSE="OTN" | ||
SLOT="0" | ||
KEYWORDS="amd64 x86" | ||
RESTRICT="fetch splitdebug" | ||
IUSE="" | ||
|
||
DEPEND="app-arch/unzip" | ||
RDEPEND="~dev-db/oracle-instantclient-basic-${PV}" | ||
|
||
S="${WORKDIR}" | ||
|
||
QA_PREBUILT="usr/lib*/oracle/${PV}/client/lib*/lib*" | ||
|
||
set_my_abivars() { | ||
MY_PLAT=MY_PLAT_${ABI}; MY_PLAT=${!MY_PLAT} # platform name | ||
MY_A=MY_A_${ABI} ; MY_A=${!MY_A} # runtime distfile | ||
# ABI sourcedir | ||
MY_S="${S}/${ABI}/instantclient_11_2" | ||
|
||
[[ -n ${MY_PLAT} ]] | ||
} | ||
|
||
pkg_nofetch() { | ||
eerror "Please go to" | ||
eerror " ${HOMEPAGE%/*}/index-097480.html" | ||
eerror " and download" | ||
local ABI | ||
for ABI in $(multilib_get_enabled_abis) | ||
do | ||
set_my_abivars || continue | ||
eerror "Instant Client for ${MY_PLAT}" | ||
eerror " ODBC: ${MY_A}" | ||
done | ||
eerror "After downloading, put them in:" | ||
eerror " ${DISTDIR}/" | ||
} | ||
|
||
src_unpack() { | ||
local ABI | ||
for ABI in $(multilib_get_enabled_abis) | ||
do | ||
set_my_abivars || continue | ||
mkdir -p "${MY_S%/*}" || die | ||
cd "${MY_S%/*}" || die | ||
unpack ${MY_A} | ||
done | ||
} | ||
|
||
src_install() { | ||
# all binaries go here | ||
local oracle_home=/usr/$(get_libdir)/oracle/${PV}/client | ||
into "${oracle_home}" | ||
|
||
local ABI | ||
for ABI in $(multilib_get_enabled_abis) | ||
do | ||
if ! set_my_abivars; then | ||
elog "Skipping unsupported ABI ${ABI}." | ||
continue | ||
fi | ||
einfo "Installing runtime for ${MY_PLAT} ..." | ||
|
||
cd "${MY_S}" || die | ||
|
||
dolib.so libsqora*$(get_libname)* | ||
|
||
# ensure to be linkable | ||
[[ -e libsqora$(get_libname) ]] || | ||
dosym libsqora$(get_libname 11.1) "${oracle_home}"/$(get_libdir)/libsqora$(get_libname) | ||
|
||
eend $? | ||
done | ||
|
||
dobin odbc_update_ini.sh | ||
dodoc *htm* | ||
} |