Skip to content

Commit

Permalink
games-util/pyfa: version bump to 2.21.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Zuber <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
ZeroPointEnergy authored and juippis committed Jun 16, 2020
1 parent 6704f73 commit 2d8155b
Show file tree
Hide file tree
Showing 2 changed files with 102 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-util/pyfa/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST pyfa-2.19.0.tar.gz 11822419 BLAKE2B 7aaa9d8fc7de7ab9fb246bdf1dd61aa4aac6035
DIST pyfa-2.20.1.tar.gz 11834967 BLAKE2B 6caf4abb5ff543aa0dc4747a853775a03e20fe8fce5f174d791429ad021ecf955895e108127182f1872f23ccad862892a1afa2e22af27aafd198100604993d62 SHA512 6e6e04f9cd6e3dd127d51c666cf88eb700cc783b02d0b31220196925bc64bb1d88ea2c6a36bc45d71ba62cc53074bd509b46edd175f02e7b1fc736af13ce41ef
DIST pyfa-2.20.2.tar.gz 11835308 BLAKE2B 3482ba068720ca735a5f794ede38dffda61ff571552c57a268263820b5b9085c6059be64c739d4ce67a9c95a1c4ba44136cb6aaa2ee7454514924e8c2de7e128 SHA512 14066b81ae77e600367255fa9ba079192f79a8d01d0194b894ba616d7a225e58141b9c2b980e99bfdf17403e665d1968e62a805f845c5065f8ed47de7950e44c
DIST pyfa-2.20.3.tar.gz 11835182 BLAKE2B 0a298f565317a4a8894fda64dc01175080bf2d6b3d118168f0015dee5988742ddca4170faa72565e5b08bbb66752668e081b142e8d8d19b5fea019dc874e5306 SHA512 0971da1b3f6db6c8e4a0d5b24c5a7f267bbf10531ea0cf98263e779c86cbea419a783088f37a7f5d2b18b7f498f525d5c80724ebaf2cff1ae1e5290e2fac5704
DIST pyfa-2.21.0.tar.gz 11876753 BLAKE2B 104dd1da117f014ff28f745cb5c89a77b7f6fdf850ba70fcbfef9d9f5d49ad053939baf356b12962dec9e32b746cd1a2b617937522dddabcaf06bc3a9c18d3bc SHA512 11ccbd1e89429176a5da24bd8bb5c896e43d78ac92b49c5374f8449cd9ade0fdb3c7370c5abe5860d7be92b7bf24b9557720f2c0c55073adc74eb517de512a4b
101 changes: 101 additions & 0 deletions games-util/pyfa/pyfa-2.21.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,101 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="sqlite"

inherit desktop eutils python-single-r1 xdg-utils

DESCRIPTION="Python Fitting Assistant - a ship fitting application for EVE Online"
HOMEPAGE="https://github.com/pyfa-org/Pyfa"

LICENSE="GPL-3+ all-rights-reserved"
SLOT="0"
if [[ ${PV} = 9999 ]]; then
EGIT_REPO_URI="https://github.com/pyfa-org/Pyfa.git"
inherit git-r3
else
SRC_URI="https://github.com/pyfa-org/Pyfa/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/Pyfa-${PV}"
fi

REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="mirror bindist"

DEPEND="
$(python_gen_cond_dep '
>=dev-python/cryptography-2.3[${PYTHON_MULTI_USEDEP}]
>=dev-python/logbook-1.0.0[${PYTHON_MULTI_USEDEP}]
>=dev-python/pyyaml-5.1[${PYTHON_MULTI_USEDEP}]
>=dev-python/sqlalchemy-1.3.0[${PYTHON_MULTI_USEDEP}]
>=dev-python/wxpython-4.0.4[webkit,${PYTHON_MULTI_USEDEP}]
')
${PYTHON_DEPS}"
RDEPEND="${DEPEND}
$(python_gen_cond_dep '
>=dev-python/beautifulsoup-4.6.0[${PYTHON_MULTI_USEDEP}]
>=dev-python/markdown2-2.3.0[${PYTHON_MULTI_USEDEP}]
>=dev-python/packaging-16.8[${PYTHON_MULTI_USEDEP}]
dev-python/python-dateutil[${PYTHON_MULTI_USEDEP}]
>=dev-python/requests-2.0.0[${PYTHON_MULTI_USEDEP}]
>=dev-python/roman-2.0.0[${PYTHON_MULTI_USEDEP}]
>=dev-python/matplotlib-3.1.2[wxwidgets,${PYTHON_MULTI_USEDEP}]
dev-python/numpy[${PYTHON_MULTI_USEDEP}]
')"
BDEPEND="app-arch/zip"

PATCHES=(
# fix import path in the main script for systemwide installation
"${FILESDIR}/${PN}-2.9.3-import-pyfa.patch"
)

src_prepare() {
# get rid of CRLF line endings introduced in 1.1.10 so patches work
edos2unix config.py pyfa.py gui/bitmap_loader.py service/settings.py

default

# make python recognize pyfa as a package
touch __init__.py || die

sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
-e "s:%%EPREFIX%%:${EPREFIX}:" \
"${FILESDIR}/configforced-1.15.1.py" > configforced.py || die
sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
pyfa.py > pyfa || die
}

src_install() {
python_moduleinto ${PN}
python_domodule eos gui service utils graphs
python_domodule config*.py __init__.py version.yml configforced.py db_update.py
python_doscript pyfa

insinto /usr/share/${PN}

einfo "Creating database ..."
python ./db_update.py || die
doins eve.db

einfo "Compressing images ..."
pushd imgs > /dev/null || die
zip -r imgs.zip * || die "zip failed"
doins imgs.zip
popd > /dev/null || die

dodoc README.md
doicon -s 32 imgs/gui/pyfa.png
newicon -s 64 imgs/gui/pyfa64.png pyfa.png
domenu "${FILESDIR}/${PN}.desktop"
}

pkg_postinst() {
xdg_icon_cache_update
}

pkg_postrm() {
xdg_icon_cache_update
}

0 comments on commit 2d8155b

Please sign in to comment.