Skip to content

Commit

Permalink
games-board/ccgo: version bump and fix building with libsigc++-2.6
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.24
  • Loading branch information
Michael Sterrett committed Dec 31, 2015
1 parent f3c8c77 commit 2df150c
Show file tree
Hide file tree
Showing 5 changed files with 86 additions and 1 deletion.
1 change: 1 addition & 0 deletions games-board/ccgo/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST ccgo-0.3.6.4.tar.gz 620246 SHA256 1975a4e9b6661f6613dd3a00b3ee7e176b80244f555a184b258b50ef4352a890 SHA512 54625bbf7036c18f4a9e92df0d7f2d67772138a940c5fdbbffa3d1c2e5c558cad5394d2c556c06388516e53d1f3502cf6369bcd95b1139d4ca5ec4210dcac5c2 WHIRLPOOL dd1b63c6c4360da99f66772373d2b9a0b39b495c57893d89cd69a4db8c0b8c53db059350c906f17a9e1402bacd473827fcce1be4d607c4afa3b1b9eb36de8f9d
DIST ccgo-0.3.6.5.tar.gz 639238 SHA256 d12be7fb9170d650ae78197983fac05af21ddbf47f7b1a2a14de9aa832ed602c SHA512 268c228eee9c42e49df333bfa0707e7b72c39731ccd64239e3c426958f6c17b65658db91bc7ab89548c4cc647ade791a7c67c30c410a5b3935c8fd3f326bf36b WHIRLPOOL 2baa70d05da8698a6115096800ccfd64dfb825c6b819fe9141141334eda53195632ae3dd5ee0031e1c145dbd9e697d6a5bdb8d9f40218c3653dda10d814e9f8d
7 changes: 6 additions & 1 deletion games-board/ccgo/ccgo-0.3.6.4.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@
# $Id$

EAPI=5
inherit autotools toolchain-funcs games
inherit autotools eutils toolchain-funcs flag-o-matic games

DESCRIPTION="An IGS client written in C++"
HOMEPAGE="http://ccdw.org/~cjj/prog/ccgo/"
Expand Down Expand Up @@ -31,6 +31,11 @@ src_prepare() {
-e '/^appicondir/s:=.*:=/usr/share/pixmaps:' \
-e '/^desktopdir/s:=.*:=/usr/share/applications:' \
Makefile.am || die
# cargo cult from bug #569528
append-cxxflags -std=c++11 -fpermissive
find . -name '*.hh' -exec sed -i -e '/sigc++\/object.h/d' {} +
find . -name '*.cc' -exec sed -i -e 's/(bind(/(sigc::bind(/' {} +
epatch "${FILESDIR}"/${P}-gcc4.patch
eautoreconf
}

Expand Down
55 changes: 55 additions & 0 deletions games-board/ccgo/ccgo-0.3.6.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,55 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit autotools eutils toolchain-funcs flag-o-matic games

DESCRIPTION="An IGS client written in C++"
HOMEPAGE="http://ccdw.org/~cjj/prog/ccgo/"
SRC_URI="http://ccdw.org/~cjj/prog/ccgo/src/${P}.tar.gz"

LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="nls"

RDEPEND=">=dev-cpp/gtkmm-2.4:2.4
>=dev-cpp/gconfmm-2.6
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
virtual/pkgconfig
nls? ( sys-devel/gettext )"

src_prepare() {
sed -i \
-e '/^Encoding/d' \
-e '/^Categories/ { s/Application;//; s/$/GTK;/ }' \
ccgo.desktop.in || die
sed -i \
-e '/^localedir/s/=.*/=@localedir@/' \
-e '/^appicondir/s:=.*:=/usr/share/pixmaps:' \
-e '/^desktopdir/s:=.*:=/usr/share/applications:' \
Makefile.am || die
# cargo cult from bug #569528
append-cxxflags -std=c++11 -fpermissive
find . -name '*.hh' -exec sed -i -e '/sigc++\/object.h/d' {} +
find . -name '*.cc' -exec sed -i -e 's/(bind(/(sigc::bind(/' {} +
epatch "${FILESDIR}"/${P}-gcc4.patch
eautoreconf
}

src_configure() {
egamesconf \
--localedir=/usr/share/locale \
$(use_enable nls)
}

src_compile() {
emake AR="$(tc-getAR)"
}

src_install() {
default
prepgamesdirs
}
12 changes: 12 additions & 0 deletions games-board/ccgo/files/ccgo-0.3.6.4-gcc4.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
--- gtk/board.cc.orig
+++ gtk/board.cc
@@ -20,9 +20,7 @@
*/

#include <config.hh>
-extern "C" {
#include <gettext.h>
-}
#define _(String) Glib::locale_to_utf8(gettext(String))

#include <board.hh>
12 changes: 12 additions & 0 deletions games-board/ccgo/files/ccgo-0.3.6.5-gcc4.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
--- gtk/board.cc.orig
+++ gtk/board.cc
@@ -20,9 +20,7 @@
*/

#include <config.hh>
-extern "C" {
#include <gettext.h>
-}
#define _(String) Glib::locale_to_utf8(gettext(String))

#include <board.hh>

0 comments on commit 2df150c

Please sign in to comment.