Skip to content

Commit

Permalink
media-libs/musicbrainz: Fix CMake error
Browse files Browse the repository at this point in the history
This fixes a build error caused by improper use of wildcards in the
project's src/CMakelists.txt file.

Closes: https://bugs.gentoo.org/698090
Signed-off-by: William Breathitt Gray <[email protected]>
Closes: gentoo#15600
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
vilhelmgray authored and a17r committed Jun 4, 2020
1 parent b5c6020 commit 2e3353e
Show file tree
Hide file tree
Showing 2 changed files with 29 additions and 0 deletions.
27 changes: 27 additions & 0 deletions media-libs/musicbrainz/files/musicbrainz-5.1.0-no-wildcards.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
From 36262d60fe92fe7a2c9bfb40e736bfcd29a6c3bd Mon Sep 17 00:00:00 2001
From: Abderrahim Kitouni <[email protected]>
Date: Fri, 13 Apr 2018 09:56:57 +0100
Subject: [PATCH 2/2] src/CMakelists.txt: do not use wildcards for dependencies

This is discouraged by cmake's documentation and doesn't work with the ninja generator.
---
src/CMakeLists.txt | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 68c04e3..f7439d3 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -37,7 +37,8 @@ ADD_CUSTOM_COMMAND(
OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/mb5_c.cc ${CMAKE_CURRENT_BINARY_DIR}/mb5_c.h ${CMAKE_CURRENT_BINARY_DIR}/../include/musicbrainz5/mb5_c.h
COMMAND make-c-interface ${CMAKE_CURRENT_SOURCE_DIR} cinterface.xml ${CMAKE_CURRENT_BINARY_DIR} mb5_c.cc mb5_c.h
COMMAND ${CMAKE_COMMAND} -E copy_if_different ${CMAKE_CURRENT_BINARY_DIR}/mb5_c.h ${CMAKE_CURRENT_BINARY_DIR}/../include/musicbrainz5/mb5_c.h
- DEPENDS make-c-interface cinterface.xml *.inc
+ DEPENDS make-c-interface cinterface.xml c-int-medium-defines.inc c-int-query-source.inc c-int-source-funcs.inc
+ c-int-medium-source.inc c-int-release-defines.inc c-int-query-defines.inc c-int-release-source.inc
)

ADD_CUSTOM_TARGET(src_gen DEPENDS mb5_c.h)
--
2.26.2

2 changes: 2 additions & 0 deletions media-libs/musicbrainz/musicbrainz-5.1.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -25,6 +25,8 @@ DEPEND="${RDEPEND}

S="${WORKDIR}/lib${P}"

PATCHES=( "${FILESDIR}/${P}-no-wildcards.patch" )

src_prepare() {
use test || cmake_comment_add_subdirectory tests
cmake-utils_src_prepare
Expand Down

0 comments on commit 2e3353e

Please sign in to comment.