Skip to content

Commit

Permalink
dev-dotnet/libgdiplus: bump to 5.6.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Mikhail Pukhlikov <[email protected]>
  • Loading branch information
cnd committed Jun 7, 2019
1 parent 5268c32 commit 2e6dcec
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-dotnet/libgdiplus/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST libgdiplus-2.10.9.tar.bz2 2074317 BLAKE2B ddbdc22d61734e9141f7d05b45867b1c0ac89903a74d23a3b05d247913aaac5350a603a5d7acb85338b2e9877b077c3c4b43839b33b2f6507b76035124cb43b4 SHA512 7f1944795c7ede5fd92a6d7e8d7d6cf2ef3c154e656b83e769b417f8f7195dd975084afe3c3cd1dda1ecb2c1167f76c0b5714cd16d549ff056add09763c6b26c
DIST libgdiplus-4.2.tar.gz 687398 BLAKE2B e9b5912cb63de9692861b09ceeb5ad55fa6999960fddbbe55382f957591e68bede91550c2d49ed4bc78d118288ca6b35a2b2ab69f87f9fcc289b7fe2b1853b7a SHA512 102d1e07a106fa32640a20c4843bf82b3f628c5b7a3813d39c7712f2cd09d80dc5adb337a8d5bdbae065f876a0c433a5d8fcb7d761dff5ee08c48cac2cd2344e
DIST libgdiplus-5.6.1.tar.gz 734255 BLAKE2B db54559b6bb6ea3f3f966de8692f08c4a042d0719b45263d3f546be1c7795a86d26943d699284acded8419a969238f58f2482090186df1b167d650343900729d SHA512 f1e477e4cbdd83f15bd8edc0feb975399c3eca042cafd1795a018f412b88ad5eb82d2cb0852d2009fdaa6f17d1c62c6b81340578f00eccc2e98ac9debe4a748e
51 changes: 51 additions & 0 deletions dev-dotnet/libgdiplus/libgdiplus-5.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit eutils

DESCRIPTION="Library for using System.Drawing with mono"
HOMEPAGE="http://www.mono-project.com"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
SRC_URI="http://download.mono-project.com/sources/${PN}/${P}.tar.gz"

IUSE="cairo"

RDEPEND=">=dev-libs/glib-2.2.3:2
>=media-libs/freetype-2.3.7
>=media-libs/fontconfig-2.6
>=media-libs/libpng-1.4:0
x11-libs/libXrender
x11-libs/libX11
x11-libs/libXt
>=x11-libs/cairo-1.8.4[X]
media-libs/libexif
>=media-libs/giflib-5.1.2
<media-libs/giflib-5.1.9
virtual/jpeg:0
media-libs/tiff:0
!cairo? ( >=x11-libs/pango-1.20 )"
DEPEND="${RDEPEND}"

src_configure() {
econf \
--disable-dependency-tracking \
--disable-static \
$(usex cairo "" "--with-pango")
}

src_install () {
default

dotnet_multilib_comply
local commondoc=( AUTHORS ChangeLog README TODO )
for docfile in "${commondoc[@]}"; do
[[ -e "${docfile}" ]] && dodoc "${docfile}"
done
[[ "${DOCS[@]}" ]] && dodoc "${DOCS[@]}"
prune_libtool_files
}

0 comments on commit 2e6dcec

Please sign in to comment.