Skip to content

Commit

Permalink
games-roguelike/nethack: version bump to 3.6.4
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/706200
Package-Manager: Portage-2.3.85, Repoman-2.3.20
Signed-off-by: Stefan Strogin <[email protected]>
  • Loading branch information
steils committed Jan 25, 2020
1 parent 90c3e53 commit 2ed9103
Show file tree
Hide file tree
Showing 2 changed files with 130 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-roguelike/nethack/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST nethack-3.6.3.tar.gz 5568657 BLAKE2B f0aa12a27fdf5005f57dcc802af88939b8460cfcfea3dc4d262b15a2807376ed434233dfa85ae0bfd60e50ad5a51ff4b060b5063e393d5859bac1b98364b5359 SHA512 38bc6140b12188397539f28528dd8e34364fb7efeb42dbe36d86fea6cc473e292b7f47fba01db19cf7641414dee86092e33deb3b074afa0e8b811e71be71e1d1
DIST nethack-3.6.4.tar.gz 5573777 BLAKE2B 4e5a48bbf521406f17bc699643dd9f9d912381cc91ab2228affc6f54ad2b84ea7c946ab2d5936c274752a36920440d34001b13f28ce4c8f35844300d596086a7 SHA512 c951f939d50027b4468ebd2e32f79771e696035df0918b814bf02899f5c1e89d462ebc3f63155c23f5c627e66ca74244512d666b102c380242df1500a2c0afa9
DIST nethack-360-src.tgz 4261282 BLAKE2B 7be22b8bdc7b5124418fa904aa3776d77440f67ec18782b878e037b989a18092ed88ca192224c7bc1eaa3cb438823188035c3e6d2aa85d13a7aa1e86c8527d32 SHA512 92370a3c60a4f6861b9c0f1e1320fc23d91cedc1615d0d09e06a0ee3e13c9c8c0cd931389bfd7a25845ed07ef966d19d9e46e77ae07084a941685dc67f49c813
DIST nethack-361-src.tgz 4640769 BLAKE2B 3793a753e4012df64335e7e7ec60284de206012d5bb5d30a7ccfb458e456818f30dd0b4bfa9c41b1691bd01ee6aec2e44b57327586f0c9d76a573bf4c9bb00b1 SHA512 bd6e36c163f0d85e1ab1fc659464696b5a02c3864a800ad47e047fdc4a35fff4ef7dd28a9b071fa46f7f67fa45c97fdc77bc1f2bdbad80cc02950d73731d9c30
129 changes: 129 additions & 0 deletions games-roguelike/nethack/nethack-3.6.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,129 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit desktop flag-o-matic toolchain-funcs

DESCRIPTION="The ultimate old-school single player dungeon exploration game"
HOMEPAGE="https://www.nethack.org/"
SRC_URI="https://nethack.org/download/${PV}/nethack-${PV//.}-src.tgz -> ${P}.tar.gz"

LICENSE="nethack"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
IUSE="X"

RDEPEND="acct-group/gamestat
sys-libs/ncurses:0=
X? (
x11-libs/libXaw
x11-libs/libXpm
x11-libs/libXt
)"
DEPEND="${RDEPEND}
X? ( x11-base/xorg-proto )
"
BDEPEND="virtual/pkgconfig
X? (
x11-apps/bdftopcf
x11-apps/mkfontscale
)"

S="${WORKDIR}/NetHack-NetHack-${PV}_Released"

src_prepare() {
eapply "${FILESDIR}/${PN}-3.6.3-recover.patch"
eapply_user

cp "${FILESDIR}/${PN}-3.6.3-hint-$(usex X x11 tty)" hint || die "Failed to copy hint file"
sys/unix/setup.sh hint || die "Failed to run setup.sh"
}

src_compile() {
append-cflags -I../include -DDLB -DSECURE -DTIMED_DELAY -DVISION_TABLES -DDUMPLOG -DSCORE_ON_BOTL
append-cflags '-DCOMPRESS=\"${EPREFIX}/bin/gzip\"' '-DCOMPRESS_EXTENSION=\".gz\"'
append-cflags "-DHACKDIR=\\\"${EPREFIX}/usr/$(get_libdir)/nethack\\\"" "-DVAR_PLAYGROUND=\\\"${EPREFIX}/var/games/nethack\\\""
append-cflags "-DDEF_PAGER=\\\"${PAGER}\\\""
append-cflags -DSYSCF "-DSYSCF_FILE=\\\"${EPREFIX}/etc/nethack.sysconf\\\""

use X && append-cflags -DX11_GRAPHICS -DUSE_XPM

LOCAL_MAKEOPTS=(
CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LFLAGS="${LDFLAGS}"
WINTTYLIB="$($(tc-getPKG_CONFIG) --libs ncurses)"
HACKDIR="${EPREFIX}/usr/$(get_libdir)/nethack" INSTDIR="${ED}/usr/$(get_libdir)/nethack"
SHELLDIR="${ED}/usr/bin" VARDIR="${ED}/var/games/nethack"
)

emake "${LOCAL_MAKEOPTS[@]}" nethack recover Guidebook spec_levs

# Upstream still has some parallel compilation bugs
emake -j1 "${LOCAL_MAKEOPTS[@]}" all
}

src_install() {
emake "${LOCAL_MAKEOPTS[@]}" install

mv "${ED}/usr/$(get_libdir)/nethack/recover" "${ED}/usr/bin/recover-nethack" || die "Failed to move recover-nethack"

doman doc/nethack.6
newman doc/recover.6 recover-nethack.6
dodoc doc/Guidebook.txt

insinto /etc
newins sys/unix/sysconf nethack.sysconf

insinto /etc/skel
newins "${FILESDIR}/${PN}-3.6.0-nethackrc" .nethackrc

if use X ; then
cd "${S}/win/X11" || die "Failed to enter win/X11 directory"

mkdir -p "${ED}/etc/X11/app-defaults/" || die "Failed to make app-defaults directory"
mv "${ED}/usr/$(get_libdir)/nethack/NetHack.ad" "${ED}/etc/X11/app-defaults/" || die "Failed to move NetHack.ad"

newicon nh_icon.xpm nethack.xpm
make_desktop_entry ${PN} Nethack

# install nethack fonts
bdftopcf -o nh10.pcf nh10.bdf || die "Converting fonts failed"
bdftopcf -o ibm.pcf ibm.bdf || die "Converting fonts failed"
insinto "/usr/$(get_libdir)/nethack/fonts"
doins *.pcf
mkfontdir "${ED}/usr/$(get_libdir)/nethack/fonts" || die "mkfontdir failed"
fi

rm -r "${ED}/var/games/nethack" || die "Failed to clean var/games/nethack"
keepdir /var/games/nethack/save
}

pkg_preinst() {
fowners root:gamestat /var/games/nethack /var/games/nethack/save
fperms 2770 /var/games/nethack /var/games/nethack/save

fowners root:gamestat "/usr/$(get_libdir)/nethack/nethack"
fperms g+s "/usr/$(get_libdir)/nethack/nethack"
}

pkg_postinst() {
cd "${EROOT}/var/games/nethack" || die "Failed to enter ${EROOT}/var/games/nethack directory"

# Transition mechanism for <nethack-3.6.1 ebuilds. It's perfectly safe, so we'll just run it unconditionally.
chmod 2770 . save || die "Failed to chmod statedir"

# Those files can't be created earlier because we don't want portage to wipe them during upgrades
( umask 007 && touch logfile perm record xlogfile ) || die "Failed to create log files"

# Instead of using a proper version header in its save files, nethack checks for incompatibilities
# by comparing the mtimes of save files and its own binary. This would require admin interaction even
# during upgrades which don't change the file format, so we'll just touch the files and warn the admin
# manually in case of compatibility issues.
(
shopt -s nullglob
local saves=( bones* save/* )
[[ -n "${saves[*]}" ]] && touch -c "${saves[@]}"
) # non-fatal

elog "A minimal default .nethackrc has been placed in /etc/skel/"
elog "The sysconf file is at /etc/nethack.sysconf"
}

0 comments on commit 2ed9103

Please sign in to comment.