Skip to content

Commit

Permalink
dev-php/PEAR-HTTP_Request2: Version bump to 2.3.0 with tests
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
Brian Evans committed Feb 16, 2018
1 parent c3c8403 commit 2f10d33
Show file tree
Hide file tree
Showing 2 changed files with 33 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/PEAR-HTTP_Request2/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST HTTP_Request2-2.2.1.tgz 107339 BLAKE2B fa9d997c7ea59aeb8c4133944d57af3dca79e937b271ad862f8ada26631a14992f204566dc2059cd19a0169f7d89ef1b302ec9fe2b4e370a8e715a0004b474f8 SHA512 377421f521184b3dc4f28b1d37a1f673ee2b40b8786e39c3803ed6c60f57a2aa8353018ea588598b7ef23a1345227a41481519932998dd01958df623d00dcd82
DIST HTTP_Request2-2.3.0.tgz 119717 BLAKE2B f12972b2423258016f4f4ef8888b5aa1d56bb47146cc6e21f74edfd2e3cd8ae69a1830b4a203990e1346554f2a6e9538e8d5feae27cceadc8465b018dd34ff37 SHA512 52fc2768f3c5afe6fd4505d427255e467b5b7cac8a4116cbabc3f1c0ffe6f1bd061a9c9b31de2ebbd4a7844ae73085ab0d52adf905dce28eb31197117657d77b
32 changes: 32 additions & 0 deletions dev-php/PEAR-HTTP_Request2/PEAR-HTTP_Request2-2.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit php-pear-r2

DESCRIPTION="Provides an easy way to perform HTTP requests"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="+curl +fileinfo +ssl test +zlib"

RDEPEND="dev-lang/php:*[curl?,fileinfo?,ssl?,zlib?]
>=dev-php/PEAR-Net_URL2-2.2.0"
DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"

src_prepare() {
sed -i "s~@data_dir@~${EPREFIX}/usr/share/php/data~" HTTP/Request2/CookieJar.php || die
default
}

src_test() {
phpunit tests || die
}

src_install() {
php-pear-r2_src_install
insinto "/usr/share/php/${PEAR_PN}"
doins data/*
}

0 comments on commit 2f10d33

Please sign in to comment.